aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-10-19 10:19:44 +0000
committerJohn Crispin <blogic@openwrt.org>2015-10-19 10:19:44 +0000
commit25eee465a964fd5f2b9d01d5baec7105b23a2a03 (patch)
tree63e5b0902144e9f8612687453bf952fcc263d988 /target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
parent874e0061cec6b2a32d259077fb1789c00bf07833 (diff)
downloadupstream-25eee465a964fd5f2b9d01d5baec7105b23a2a03.tar.gz
upstream-25eee465a964fd5f2b9d01d5baec7105b23a2a03.tar.bz2
upstream-25eee465a964fd5f2b9d01d5baec7105b23a2a03.zip
ar71xx: Add support for WeIO board
Support for WeIO board (http://we-io.net), backported from Designated Driver trunk. Signed-off-by: Drasko DRASKOVIC <drasko.draskovic@gmail.com> Backport of r47110 git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@47232 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch')
-rw-r--r--target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch21
1 files changed, 16 insertions, 5 deletions
diff --git a/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch b/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
index 8f46d1a9aa..2fa041ba93 100644
--- a/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
+++ b/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/ath79/machtypes.h
+++ b/arch/mips/ath79/machtypes.h
-@@ -16,22 +16,196 @@
+@@ -16,22 +16,197 @@
enum ath79_mach_type {
ATH79_MACH_GENERIC = 0,
@@ -165,6 +165,7 @@
ATH79_MACH_UBNT_UNIFI_OUTDOOR, /* Ubiquiti UnifiAP Outdoor */
+ ATH79_MACH_UBNT_UNIFI_OUTDOOR_PLUS, /* Ubiquiti UnifiAP Outdoor+ */
ATH79_MACH_UBNT_XM, /* Ubiquiti Networks XM board rev 1.0 */
++ ATH79_MACH_WEIO, /* WeIO board */
+ ATH79_MACH_WHR_G301N, /* Buffalo WHR-G301N */
+ ATH79_MACH_WHR_HP_G300N, /* Buffalo WHR-HP-G300N */
+ ATH79_MACH_WHR_HP_GN, /* Buffalo WHR-HP-GN */
@@ -1340,10 +1341,19 @@
config ATH79_MACH_UBNT_XM
bool "Ubiquiti Networks XM/UniFi boards"
-@@ -83,6 +1126,97 @@ config ATH79_MACH_UBNT_XM
+@@ -83,6 +1126,106 @@ config ATH79_MACH_UBNT_XM
Say 'Y' here if you want your kernel to support the
Ubiquiti Networks XM (rev 1.0) board.
++config ATH79_MACH_WEIO
++ bool "WeIO board"
++ select SOC_AR933X
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_USB
++ select ATH79_DEV_WMAC
++
+config ATH79_MACH_MYNET_N600
+ bool "WD My Net N600 board support"
+ select SOC_AR934X
@@ -1438,7 +1448,7 @@
endmenu
config SOC_AR71XX
-@@ -124,7 +1258,10 @@ config ATH79_DEV_DSA
+@@ -124,7 +1267,10 @@ config ATH79_DEV_DSA
config ATH79_DEV_ETH
def_bool n
@@ -1450,7 +1460,7 @@
def_bool n
config ATH79_DEV_GPIO_BUTTONS
-@@ -154,6 +1291,11 @@ config ATH79_PCI_ATH9K_FIXUP
+@@ -154,6 +1300,11 @@ config ATH79_PCI_ATH9K_FIXUP
def_bool n
config ATH79_ROUTERBOOT
@@ -1464,7 +1474,7 @@
endif
--- a/arch/mips/ath79/Makefile
+++ b/arch/mips/ath79/Makefile
-@@ -38,9 +38,125 @@ obj-$(CONFIG_ATH79_ROUTERBOOT) += route
+@@ -38,9 +38,126 @@ obj-$(CONFIG_ATH79_ROUTERBOOT) += route
#
# Machines
#
@@ -1565,6 +1575,7 @@
+obj-$(CONFIG_ATH79_MACH_TUBE2H) += mach-tube2h.o
+obj-$(CONFIG_ATH79_MACH_UBNT) += mach-ubnt.o
obj-$(CONFIG_ATH79_MACH_UBNT_XM) += mach-ubnt-xm.o
++obj-$(CONFIG_ATH79_MACH_WEIO) += mach-weio.o
+obj-$(CONFIG_ATH79_MACH_WHR_HP_G300N) += mach-whr-hp-g300n.o
+obj-$(CONFIG_ATH79_MACH_WLAE_AG300N) += mach-wlae-ag300n.o
+obj-$(CONFIG_ATH79_MACH_WLR8100) += mach-wlr8100.o