aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.18/435-spi-vsc7385_driver.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-02-15 19:45:29 +0000
committerJohn Crispin <john@openwrt.org>2015-02-15 19:45:29 +0000
commit7e4b3de2493f024432935e283f5eeb2920957871 (patch)
tree10524efa8132ebe05e93a75a10ef3ca733edea0e /target/linux/ar71xx/patches-3.18/435-spi-vsc7385_driver.patch
parent9b1c7a9de4a2734b701660a9f3720e842626aea3 (diff)
downloadupstream-7e4b3de2493f024432935e283f5eeb2920957871.tar.gz
upstream-7e4b3de2493f024432935e283f5eeb2920957871.tar.bz2
upstream-7e4b3de2493f024432935e283f5eeb2920957871.zip
ar71xx: add v3.18 support
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 44456
Diffstat (limited to 'target/linux/ar71xx/patches-3.18/435-spi-vsc7385_driver.patch')
-rw-r--r--target/linux/ar71xx/patches-3.18/435-spi-vsc7385_driver.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.18/435-spi-vsc7385_driver.patch b/target/linux/ar71xx/patches-3.18/435-spi-vsc7385_driver.patch
new file mode 100644
index 0000000000..95c77dfe15
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.18/435-spi-vsc7385_driver.patch
@@ -0,0 +1,24 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -662,6 +662,11 @@ config SPI_RB4XX_CPLD
+ SPI driver for the Xilinx CPLD chip present on the
+ MikroTik RB4xx boards.
+
++config SPI_VSC7385
++ tristate "Vitesse VSC7385 ethernet switch driver"
++ help
++ SPI driver for the Vitesse VSC7385 ethernet switch.
++
+ #
+ # Add new SPI protocol masters in alphabetical order above this line
+ #
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -86,6 +86,7 @@ obj-$(CONFIG_SPI_TEGRA20_SLINK) += spi-
+ obj-$(CONFIG_SPI_TLE62X0) += spi-tle62x0.o
+ obj-$(CONFIG_SPI_TOPCLIFF_PCH) += spi-topcliff-pch.o
+ obj-$(CONFIG_SPI_TXX9) += spi-txx9.o
++obj-$(CONFIG_SPI_VSC7385) += spi-vsc7385.o
+ obj-$(CONFIG_SPI_XCOMM) += spi-xcomm.o
+ obj-$(CONFIG_SPI_XILINX) += spi-xilinx.o
+ obj-$(CONFIG_SPI_XTENSA_XTFPGA) += spi-xtensa-xtfpga.o