aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.14/435-spi-vsc7385_driver.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-08-07 12:40:53 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-08-07 12:40:53 +0000
commite41a0cafff16f2443e587884782172c6d8478771 (patch)
tree2ab441d85607622857c5d7602918d24312daa7ab /target/linux/ar71xx/patches-3.14/435-spi-vsc7385_driver.patch
parentf75f9606ad6af9f4c62acd45741a7e3880ad7dbb (diff)
downloadupstream-e41a0cafff16f2443e587884782172c6d8478771.tar.gz
upstream-e41a0cafff16f2443e587884782172c6d8478771.tar.bz2
upstream-e41a0cafff16f2443e587884782172c6d8478771.zip
ar71xx: add linux 3.14 support
Signed-off-by: Zhao, Gang <gang.zhao.42@gmail.com> Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 42038
Diffstat (limited to 'target/linux/ar71xx/patches-3.14/435-spi-vsc7385_driver.patch')
-rw-r--r--target/linux/ar71xx/patches-3.14/435-spi-vsc7385_driver.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.14/435-spi-vsc7385_driver.patch b/target/linux/ar71xx/patches-3.14/435-spi-vsc7385_driver.patch
new file mode 100644
index 0000000000..9c153e9286
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.14/435-spi-vsc7385_driver.patch
@@ -0,0 +1,23 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -601,6 +601,11 @@ config SPI_RB4XX_CPLD
+ SPI driver for the Xilinx CPLD chip present on the
+ MikroTik RB4xx boards.
+
++config SPI_VSC7385
++ tristate "Vitesse VSC7385 ethernet switch driver"
++ help
++ SPI driver for the Vitesse VSC7385 ethernet switch.
++
+ #
+ # Add new SPI protocol masters in alphabetical order above this line
+ #
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -81,5 +81,6 @@ obj-$(CONFIG_SPI_TI_SSP) += spi-ti-ssp.
+ obj-$(CONFIG_SPI_TLE62X0) += spi-tle62x0.o
+ obj-$(CONFIG_SPI_TOPCLIFF_PCH) += spi-topcliff-pch.o
+ obj-$(CONFIG_SPI_TXX9) += spi-txx9.o
++obj-$(CONFIG_SPI_VSC7385) += spi-vsc7385.o
+ obj-$(CONFIG_SPI_XCOMM) += spi-xcomm.o
+ obj-$(CONFIG_SPI_XILINX) += spi-xilinx.o