aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.10
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-11-03 20:20:56 +0000
committerJohn Crispin <blogic@openwrt.org>2014-11-03 20:20:56 +0000
commit1b0343012a2aeb8fd6e06fadd79daba7a2db59d9 (patch)
treee3ba1b63957cb091e469fbc94a44208d14025213 /target/linux/ar71xx/patches-3.10
parentebf8e128cc2d1e1e3318d89251d33598cc16874e (diff)
downloadupstream-1b0343012a2aeb8fd6e06fadd79daba7a2db59d9.tar.gz
upstream-1b0343012a2aeb8fd6e06fadd79daba7a2db59d9.tar.bz2
upstream-1b0343012a2aeb8fd6e06fadd79daba7a2db59d9.zip
ar71xx: add support for Netgear WNR2000v4
Signed-off-by: Michaƫl Burtin <mburtin@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43173 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-3.10')
-rw-r--r--target/linux/ar71xx/patches-3.10/634-MIPS-ath79-WNR2000V4-support.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.10/634-MIPS-ath79-WNR2000V4-support.patch b/target/linux/ar71xx/patches-3.10/634-MIPS-ath79-WNR2000V4-support.patch
new file mode 100644
index 0000000000..270095a962
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.10/634-MIPS-ath79-WNR2000V4-support.patch
@@ -0,0 +1,39 @@
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -470,6 +470,16 @@ config ATH79_MACH_WNR2000_V3
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_USB
+
++config ATH79_MACH_WNR2000_V4
++ bool "NETGEAR WNR2000 V4"
++ select SOC_AR934X
++ select ATH79_DEV_ETH
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_USB
++ select ATH79_DEV_WMAC
++
+ config ATH79_MACH_OM2P
+ bool "OpenMesh OM2P board support"
+ select SOC_AR724X
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -113,6 +113,7 @@ obj-$(CONFIG_ATH79_MACH_WNDR3700) += mac
+ obj-$(CONFIG_ATH79_MACH_WNDR4300) += mach-wndr4300.o
+ obj-$(CONFIG_ATH79_MACH_WNR2000) += mach-wnr2000.o
+ obj-$(CONFIG_ATH79_MACH_WNR2000_V3) += mach-wnr2000-v3.o
++obj-$(CONFIG_ATH79_MACH_WNR2000_V4) += mach-wnr2000-v4.o
+ obj-$(CONFIG_ATH79_MACH_WNR2200) += mach-wnr2200.o
+ obj-$(CONFIG_ATH79_MACH_WP543) += mach-wp543.o
+ obj-$(CONFIG_ATH79_MACH_WPE72) += mach-wpe72.o
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -138,6 +138,7 @@ enum ath79_mach_type {
+ ATH79_MACH_WNDR4300, /* NETGEAR WNDR4300 */
+ ATH79_MACH_WNR2000, /* NETGEAR WNR2000 */
+ ATH79_MACH_WNR2000_V3, /* NETGEAR WNR2000 v3 */
++ ATH79_MACH_WNR2000_V4, /* NETGEAR WNR2000 v4 */
+ ATH79_MACH_WNR2200, /* NETGEAR WNR2200 */
+ ATH79_MACH_WNR612_V2, /* NETGEAR WNR612 v2 */
+ ATH79_MACH_WP543, /* Compex WP543 */