aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.10
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-11-11 08:04:46 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-11-11 08:04:46 +0000
commit1d90d21b2517f3360426586763e74ac3be504ff5 (patch)
treea45a84e7d76bccc7e4238744701b68ecbabadfca /target/linux/ar71xx/patches-3.10
parent02885cd80a65456107a0dc5a27e24b8e7a0852aa (diff)
downloadupstream-1d90d21b2517f3360426586763e74ac3be504ff5.tar.gz
upstream-1d90d21b2517f3360426586763e74ac3be504ff5.tar.bz2
upstream-1d90d21b2517f3360426586763e74ac3be504ff5.zip
ar71xx: Add kernel support for the TP-Link WA750RE / WA850RE range extender
Patch to add kernel support for the TP-LINK WA750RE and the WA850RE range extender Signed-off-by: Martijn Zilverschoon <thefriedzombie@gmail.com> [juhosg: rename and refresh kernel patch] Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38717 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-3.10')
-rw-r--r--target/linux/ar71xx/patches-3.10/633-MIPS-ath79-add-TL-WAX50RE-support.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.10/633-MIPS-ath79-add-TL-WAX50RE-support.patch b/target/linux/ar71xx/patches-3.10/633-MIPS-ath79-add-TL-WAX50RE-support.patch
new file mode 100644
index 0000000000..f3a9c95e37
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.10/633-MIPS-ath79-add-TL-WAX50RE-support.patch
@@ -0,0 +1,40 @@
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -588,6 +588,15 @@ config ATH79_MACH_TL_MR3X20
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_USB
+
++config ATH79_MACH_TL_WAX50RE
++ bool "TP-LINK TL-WA750/850RE support"
++ select SOC_AR934X
++ select ATH79_DEV_ETH
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_WMAC
++
+ config ATH79_MACH_TL_WA901ND
+ bool "TP-LINK TL-WA901ND/TL-WA7510N support"
+ select SOC_AR724X
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -88,6 +88,7 @@ obj-$(CONFIG_ATH79_MACH_TL_MR11U) += mac
+ obj-$(CONFIG_ATH79_MACH_TL_MR13U) += mach-tl-mr13u.o
+ obj-$(CONFIG_ATH79_MACH_TL_MR3020) += mach-tl-mr3020.o
+ obj-$(CONFIG_ATH79_MACH_TL_MR3X20) += mach-tl-mr3x20.o
++obj-$(CONFIG_ATH79_MACH_TL_WAX50RE) += mach-tl-wax50re.o
+ obj-$(CONFIG_ATH79_MACH_TL_WA901ND) += mach-tl-wa901nd.o
+ obj-$(CONFIG_ATH79_MACH_TL_WA901ND_V2) += mach-tl-wa901nd-v2.o
+ obj-$(CONFIG_ATH79_MACH_TL_WDR3500) += mach-tl-wdr3500.o
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -97,7 +97,9 @@ enum ath79_mach_type {
+ ATH79_MACH_TL_MR3220_V2, /* TP-LINK TL-MR3220 v2 */
+ ATH79_MACH_TL_MR3420, /* TP-LINK TL-MR3420 */
+ ATH79_MACH_TL_MR3420_V2, /* TP-LINK TL-MR3420 v2 */
++ ATH79_MACH_TL_WA750RE, /* TP-LINK TL-WA750RE */
+ ATH79_MACH_TL_WA7510N_V1, /* TP-LINK TL-WA7510N v1*/
++ ATH79_MACH_TL_WA850RE, /* TP-LINK TL-WA850RE */
+ ATH79_MACH_TL_WA901ND, /* TP-LINK TL-WA901ND */
+ ATH79_MACH_TL_WA901ND_V2, /* TP-LINK TL-WA901ND v2 */
+ ATH79_MACH_TL_WDR3500, /* TP-LINK TL-WDR3500 */