aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.10/435-spi-vsc7385_driver.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-07-09 12:52:18 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-07-09 12:52:18 +0000
commitf42a1b166f43219853c00dc21f25b0254efbbceb (patch)
tree8fac5ee67f0a836a95385d15ae8f729d34660b9e /target/linux/ar71xx/patches-3.10/435-spi-vsc7385_driver.patch
parentf56e62651455e1a7cdae45a4a12d5258e57dbb75 (diff)
downloadupstream-f42a1b166f43219853c00dc21f25b0254efbbceb.tar.gz
upstream-f42a1b166f43219853c00dc21f25b0254efbbceb.tar.bz2
upstream-f42a1b166f43219853c00dc21f25b0254efbbceb.zip
ar71xx: add linux 3.10
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37214 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-3.10/435-spi-vsc7385_driver.patch')
-rw-r--r--target/linux/ar71xx/patches-3.10/435-spi-vsc7385_driver.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.10/435-spi-vsc7385_driver.patch b/target/linux/ar71xx/patches-3.10/435-spi-vsc7385_driver.patch
new file mode 100644
index 0000000000..61385a1f4e
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.10/435-spi-vsc7385_driver.patch
@@ -0,0 +1,23 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -561,6 +561,11 @@ config SPI_RB4XX_CPLD
+ SPI driver for the Xilinx CPLD chip present on the
+ MikroTik RB4xx boards.
+
++config SPI_VSC7385
++ tristate "Vitesse VSC7385 ethernet switch driver"
++ help
++ SPI driver for the Vitesse VSC7385 ethernet switch.
++
+ #
+ # Add new SPI protocol masters in alphabetical order above this line
+ #
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -76,5 +76,6 @@ obj-$(CONFIG_SPI_TI_SSP) += spi-ti-ssp.
+ obj-$(CONFIG_SPI_TLE62X0) += spi-tle62x0.o
+ obj-$(CONFIG_SPI_TOPCLIFF_PCH) += spi-topcliff-pch.o
+ obj-$(CONFIG_SPI_TXX9) += spi-txx9.o
++obj-$(CONFIG_SPI_VSC7385) += spi-vsc7385.o
+ obj-$(CONFIG_SPI_XCOMM) += spi-xcomm.o
+ obj-$(CONFIG_SPI_XILINX) += spi-xilinx.o