aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.38/206-nxp-74hc153-gpio-chip-driver.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2011-04-21 11:45:23 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2011-04-21 11:45:23 +0000
commit015b010f90daa928dbcba6c5c8dfb4085b41695d (patch)
tree4965132c38610fa2c5bbb70481436137a225dd52 /target/linux/ar71xx/patches-2.6.38/206-nxp-74hc153-gpio-chip-driver.patch
parent6986b1b7c2aa4835bd173e3bc25a38c3f0245dee (diff)
downloadupstream-015b010f90daa928dbcba6c5c8dfb4085b41695d.tar.gz
upstream-015b010f90daa928dbcba6c5c8dfb4085b41695d.tar.bz2
upstream-015b010f90daa928dbcba6c5c8dfb4085b41695d.zip
linux/ar71xx: add 2.6.38 preliminary support
SVN-Revision: 26746
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.38/206-nxp-74hc153-gpio-chip-driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.38/206-nxp-74hc153-gpio-chip-driver.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.38/206-nxp-74hc153-gpio-chip-driver.patch b/target/linux/ar71xx/patches-2.6.38/206-nxp-74hc153-gpio-chip-driver.patch
new file mode 100644
index 0000000000..1ff83294a3
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.38/206-nxp-74hc153-gpio-chip-driver.patch
@@ -0,0 +1,25 @@
+--- a/drivers/gpio/Kconfig
++++ b/drivers/gpio/Kconfig
+@@ -411,4 +411,12 @@ config GPIO_JANZ_TTL
+ This driver provides support for driving the pins in output
+ mode only. Input mode is not supported.
+
++comment "Other GPIO expanders"
++
++config GPIO_NXP_74HC153
++ tristate "NXP 74HC153 Dual 4-input multiplexer"
++ help
++ Platform driver for NXP 74HC153 Dual 4-input Multiplexer. This
++ provides a GPIO interface supporting inputs.
++
+ endif
+--- a/drivers/gpio/Makefile
++++ b/drivers/gpio/Makefile
+@@ -18,6 +18,7 @@ obj-$(CONFIG_GPIO_MAX7301) += max7301.o
+ obj-$(CONFIG_GPIO_MAX732X) += max732x.o
+ obj-$(CONFIG_GPIO_MC33880) += mc33880.o
+ obj-$(CONFIG_GPIO_MCP23S08) += mcp23s08.o
++obj-$(CONFIG_GPIO_NXP_74HC153) += nxp_74hc153.o
+ obj-$(CONFIG_GPIO_74X164) += 74x164.o
+ obj-$(CONFIG_GPIO_PCA953X) += pca953x.o
+ obj-$(CONFIG_GPIO_PCF857X) += pcf857x.o