aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.38/109-mtd-wrt160nl-trx-parser.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-06-29 08:57:34 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-06-29 08:57:34 +0000
commite3ddb93897e66e3a24eecb30888f95022cf32bcf (patch)
tree5ed144cb01be29c813a02eb40cd35b19cbf9d093 /target/linux/ar71xx/patches-2.6.38/109-mtd-wrt160nl-trx-parser.patch
parent66550a7032931be5f2f8878b7316087ed605cb56 (diff)
downloadupstream-e3ddb93897e66e3a24eecb30888f95022cf32bcf.tar.gz
upstream-e3ddb93897e66e3a24eecb30888f95022cf32bcf.tar.bz2
upstream-e3ddb93897e66e3a24eecb30888f95022cf32bcf.zip
ar71xx: remove 2.6.38 support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27312 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.38/109-mtd-wrt160nl-trx-parser.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.38/109-mtd-wrt160nl-trx-parser.patch44
1 files changed, 0 insertions, 44 deletions
diff --git a/target/linux/ar71xx/patches-2.6.38/109-mtd-wrt160nl-trx-parser.patch b/target/linux/ar71xx/patches-2.6.38/109-mtd-wrt160nl-trx-parser.patch
deleted file mode 100644
index 294d873997..0000000000
--- a/target/linux/ar71xx/patches-2.6.38/109-mtd-wrt160nl-trx-parser.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- a/drivers/mtd/devices/m25p80.c
-+++ b/drivers/mtd/devices/m25p80.c
-@@ -984,6 +984,16 @@ static int __devinit m25p_probe(struct s
- part_probes, &parts, 0);
- }
- #endif
-+
-+#ifdef CONFIG_MTD_WRT160NL_PARTS
-+ if (nr_parts <= 0) {
-+ static const char *part_probes[]
-+ = { "wrt160nl", NULL, };
-+
-+ nr_parts = parse_mtd_partitions(&flash->mtd,
-+ part_probes, &parts, 0);
-+ }
-+#endif
- if (nr_parts <= 0 && data && data->parts) {
- parts = data->parts;
- nr_parts = data->nr_parts;
---- a/drivers/mtd/Kconfig
-+++ b/drivers/mtd/Kconfig
-@@ -184,6 +184,12 @@ config MTD_AR7_PARTS
-
- endif # MTD_PARTITIONS
-
-+config MTD_WRT160NL_PARTS
-+ tristate "Linksys WRT160NL partitioning support"
-+ depends on MTD_PARTITIONS && AR71XX_MACH_WRT160NL
-+ ---help---
-+ Linksys WRT160NL partitioning support
-+
- config MTD_MYLOADER_PARTS
- tristate "MyLoader partition parsing"
- depends on MTD_PARTITIONS && (ADM5120 || ATHEROS_AR231X || ATHEROS_AR71XX)
---- a/drivers/mtd/Makefile
-+++ b/drivers/mtd/Makefile
-@@ -13,6 +13,7 @@ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redbo
- obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
- obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
- obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
-+obj-$(CONFIG_MTD_WRT160NL_PARTS) += wrt160nl_part.o
- obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
-
- # 'Users' - code which presents functionality to userspace.