aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.37/206-nxp-74hc153-gpio-chip-driver.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-11-10 16:23:42 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-11-10 16:23:42 +0000
commit283e5476068c9072e4416e0b3181be2a3c5f2a93 (patch)
tree9faac6512fdb7dc7b2bc41ebd9ae8fcbb341aa7e /target/linux/ar71xx/patches-2.6.37/206-nxp-74hc153-gpio-chip-driver.patch
parentae3afbb5cadd9901c5f9d8a82e9248e3c9de405f (diff)
downloadupstream-283e5476068c9072e4416e0b3181be2a3c5f2a93.tar.gz
upstream-283e5476068c9072e4416e0b3181be2a3c5f2a93.tar.bz2
upstream-283e5476068c9072e4416e0b3181be2a3c5f2a93.zip
linux/ar71xx: add preliminary 2.6.37 kernel support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23944 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.37/206-nxp-74hc153-gpio-chip-driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.37/206-nxp-74hc153-gpio-chip-driver.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.37/206-nxp-74hc153-gpio-chip-driver.patch b/target/linux/ar71xx/patches-2.6.37/206-nxp-74hc153-gpio-chip-driver.patch
new file mode 100644
index 0000000000..394996ece7
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.37/206-nxp-74hc153-gpio-chip-driver.patch
@@ -0,0 +1,25 @@
+--- a/drivers/gpio/Kconfig
++++ b/drivers/gpio/Kconfig
+@@ -401,4 +401,12 @@ config GPIO_JANZ_TTL
+ This driver provides support for driving the pins in output
+ mode only. Input mode is not supported.
+
++comment "Other GPIO expanders"
++
++config GPIO_NXP_74HC153
++ tristate "NXP 74HC153 Dual 4-input multiplexer"
++ help
++ Platform driver for NXP 74HC153 Dual 4-input Multiplexer. This
++ provides a GPIO interface supporting inputs.
++
+ endif
+--- a/drivers/gpio/Makefile
++++ b/drivers/gpio/Makefile
+@@ -18,6 +18,7 @@ obj-$(CONFIG_GPIO_MAX7301) += max7301.o
+ obj-$(CONFIG_GPIO_MAX732X) += max732x.o
+ obj-$(CONFIG_GPIO_MC33880) += mc33880.o
+ obj-$(CONFIG_GPIO_MCP23S08) += mcp23s08.o
++obj-$(CONFIG_GPIO_NXP_74HC153) += nxp_74hc153.o
+ obj-$(CONFIG_GPIO_74X164) += 74x164.o
+ obj-$(CONFIG_GPIO_PCA953X) += pca953x.o
+ obj-$(CONFIG_GPIO_PCF857X) += pcf857x.o