aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.37/101-ksz8041_phy_driver.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-11-10 16:23:42 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-11-10 16:23:42 +0000
commit0c66bb9c5534b27bd4304ba4a65a3cc43fe77de5 (patch)
tree2b1fddffd4b343074e5d02e8aa267ece51e44cab /target/linux/ar71xx/patches-2.6.37/101-ksz8041_phy_driver.patch
parentcec876fe24ae1883cf11d8a014238a95a618a2b6 (diff)
downloadupstream-0c66bb9c5534b27bd4304ba4a65a3cc43fe77de5.tar.gz
upstream-0c66bb9c5534b27bd4304ba4a65a3cc43fe77de5.tar.bz2
upstream-0c66bb9c5534b27bd4304ba4a65a3cc43fe77de5.zip
linux/ar71xx: add preliminary 2.6.37 kernel support
SVN-Revision: 23944
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.37/101-ksz8041_phy_driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.37/101-ksz8041_phy_driver.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.37/101-ksz8041_phy_driver.patch b/target/linux/ar71xx/patches-2.6.37/101-ksz8041_phy_driver.patch
new file mode 100644
index 0000000000..32447e5f26
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.37/101-ksz8041_phy_driver.patch
@@ -0,0 +1,24 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -118,6 +118,11 @@ config RTL8306_PHY
+ tristate "Driver for Realtek RTL8306S switches"
+ select SWCONFIG
+
++config MICREL_PHY
++ tristate "Drivers for Micrel/Kendin PHYs"
++ ---help---
++ Currently has a driver for the KSZ8041
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -24,6 +24,7 @@ obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi
+ obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
+ obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
++obj-$(CONFIG_MICREL) += micrel.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
+ obj-$(CONFIG_MDIO_GPIO) += mdio-gpio.o