aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.36/207-rb750-led-driver.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-10-08 12:10:18 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-10-08 12:10:18 +0000
commit458e8736fc0646f892b77f50e80a24579058bb71 (patch)
treee494f3d2404aa25abfad2345748c0f85dc328678 /target/linux/ar71xx/patches-2.6.36/207-rb750-led-driver.patch
parent38e3474542eded63b16cf90a60eb5fa1ec2b9dcf (diff)
downloadupstream-458e8736fc0646f892b77f50e80a24579058bb71.tar.gz
upstream-458e8736fc0646f892b77f50e80a24579058bb71.tar.bz2
upstream-458e8736fc0646f892b77f50e80a24579058bb71.zip
linux/ar71xx: add preliminary 2.6.36 kernel support (refresh patches)
SVN-Revision: 23317
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.36/207-rb750-led-driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.36/207-rb750-led-driver.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.36/207-rb750-led-driver.patch b/target/linux/ar71xx/patches-2.6.36/207-rb750-led-driver.patch
new file mode 100644
index 0000000000..9e4ba2cd1c
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.36/207-rb750-led-driver.patch
@@ -0,0 +1,23 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -327,6 +327,10 @@ config LEDS_WNDR3700_USB
+ This option enables support for the USB LED found on the
+ NETGEAR WNDR3700 board.
+
++config LEDS_RB750
++ tristate "LED driver for the Mikrotik RouterBOARD 750"
++ depends on LEDS_CLASS && AR71XX_MACH_RB750
++
+ comment "LED Triggers"
+
+ config LEDS_TRIGGER_TIMER
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -38,6 +38,7 @@ obj-$(CONFIG_LEDS_LT3593) += leds-lt359
+ obj-$(CONFIG_LEDS_ADP5520) += leds-adp5520.o
+ obj-$(CONFIG_LEDS_DELL_NETBOOKS) += dell-led.o
+ obj-$(CONFIG_LEDS_MC13783) += leds-mc13783.o
++obj-$(CONFIG_LEDS_RB750) += leds-rb750.o
+ obj-$(CONFIG_LEDS_NS2) += leds-ns2.o
+
+ # LED SPI Drivers