aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.35/202-spi_vsc7385_driver.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-06-09 10:45:47 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-06-09 10:45:47 +0000
commitd45dc5e820b5589662236143a68928eaec01e83e (patch)
tree64a1434b436174e77545a6b7234612c5f0fdb3da /target/linux/ar71xx/patches-2.6.35/202-spi_vsc7385_driver.patch
parentbef7ceff095e5e648b45b4cf0c73fb7ad588b676 (diff)
downloadupstream-d45dc5e820b5589662236143a68928eaec01e83e.tar.gz
upstream-d45dc5e820b5589662236143a68928eaec01e83e.tar.bz2
upstream-d45dc5e820b5589662236143a68928eaec01e83e.zip
ar71xx: add kernel 2.6.35 preliminary support
SVN-Revision: 21734
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.35/202-spi_vsc7385_driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.35/202-spi_vsc7385_driver.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.35/202-spi_vsc7385_driver.patch b/target/linux/ar71xx/patches-2.6.35/202-spi_vsc7385_driver.patch
new file mode 100644
index 0000000000..b0bb15fcef
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.35/202-spi_vsc7385_driver.patch
@@ -0,0 +1,24 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -386,6 +386,11 @@ config SPI_TLE62X0
+ sysfs interface, with each line presented as a kind of GPIO
+ exposing both switch control and diagnostic feedback.
+
++config SPI_VSC7385
++ tristate "Vitesse VSC7385 ethernet switch driver"
++ help
++ SPI driver for the Vitesse VSC7385 ethernet switch.
++
+ #
+ # Add new SPI protocol masters in alphabetical order above this line
+ #
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -57,6 +57,7 @@ spi_s3c24xx_hw-$(CONFIG_SPI_S3C24XX_FIQ)
+
+ # SPI protocol drivers (device/link on bus)
+ obj-$(CONFIG_SPI_SPIDEV) += spidev.o
++obj-$(CONFIG_SPI_VSC7385) += spi_vsc7385.o
+ obj-$(CONFIG_SPI_TLE62X0) += tle62x0.o
+ # ... add above this line ...
+