aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.34/207-rb750-led-driver.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-03-11 12:25:50 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-03-11 12:25:50 +0000
commit72c480213013934d1ce989efefa7baf928938966 (patch)
treec11fd631e3247af63ba31df855de079df178c611 /target/linux/ar71xx/patches-2.6.34/207-rb750-led-driver.patch
parent29fec42733aec697e4bd5edf0be9f4d803853ef1 (diff)
downloadupstream-72c480213013934d1ce989efefa7baf928938966.tar.gz
upstream-72c480213013934d1ce989efefa7baf928938966.tar.bz2
upstream-72c480213013934d1ce989efefa7baf928938966.zip
ar71xx: add 2.6.34 preliminary support (patches)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20141 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.34/207-rb750-led-driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.34/207-rb750-led-driver.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.34/207-rb750-led-driver.patch b/target/linux/ar71xx/patches-2.6.34/207-rb750-led-driver.patch
new file mode 100644
index 0000000000..500604fe22
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.34/207-rb750-led-driver.patch
@@ -0,0 +1,23 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -276,6 +276,10 @@ config LEDS_WNDR3700_USB
+ This option enables support for the USB LED found on the
+ NETGEAR WNDR3700 board.
+
++config LEDS_RB750
++ tristate "LED driver for the Mikrotik RouterBOARD 750"
++ depends on LEDS_CLASS && AR71XX_MACH_RB750
++
+ comment "LED Triggers"
+
+ config LEDS_TRIGGERS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -34,6 +34,7 @@ obj-$(CONFIG_LEDS_REGULATOR) += leds-re
+ obj-$(CONFIG_LEDS_INTEL_SS4200) += leds-ss4200.o
+ obj-$(CONFIG_LEDS_LT3593) += leds-lt3593.o
+ obj-$(CONFIG_LEDS_ADP5520) += leds-adp5520.o
++obj-$(CONFIG_LEDS_RB750) += leds-rb750.o
+
+ # LED SPI Drivers
+ obj-$(CONFIG_LEDS_DAC124S085) += leds-dac124s085.o