aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.33/203-pb44_spi_controller.patch
diff options
context:
space:
mode:
authorMatteo Croce <rootkit85@yahoo.it>2010-02-28 16:33:15 +0000
committerMatteo Croce <rootkit85@yahoo.it>2010-02-28 16:33:15 +0000
commita15d58f605a776ee9a929fc46d52bfc7afc70de0 (patch)
tree9b12d235a2990389a0943f0bd707eed0d31a1e33 /target/linux/ar71xx/patches-2.6.33/203-pb44_spi_controller.patch
parent2cb1d98fc227357486a22cfe9ce8fd9484ea2a1d (diff)
downloadupstream-a15d58f605a776ee9a929fc46d52bfc7afc70de0.tar.gz
upstream-a15d58f605a776ee9a929fc46d52bfc7afc70de0.tar.bz2
upstream-a15d58f605a776ee9a929fc46d52bfc7afc70de0.zip
ar71xx: 2.6.33 patches
SVN-Revision: 19908
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.33/203-pb44_spi_controller.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.33/203-pb44_spi_controller.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.33/203-pb44_spi_controller.patch b/target/linux/ar71xx/patches-2.6.33/203-pb44_spi_controller.patch
new file mode 100644
index 0000000000..e48710ca91
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.33/203-pb44_spi_controller.patch
@@ -0,0 +1,27 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -68,6 +68,14 @@ config SPI_AR71XX
+ help
+ This is the SPI contoller driver for Atheros AR71xx.
+
++config SPI_PB44
++ tristate "Atheros PB44 board specific SPI controller"
++ depends on SPI_MASTER && AR71XX_MACH_PB44
++ select SPI_BITBANG
++ help
++ This is a specific SPI controller driver for the Atheros PB44
++ reference board.
++
+ config SPI_ATMEL
+ tristate "Atmel SPI Controller"
+ depends on (ARCH_AT91 || AVR32)
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -22,6 +22,7 @@ obj-$(CONFIG_SPI_GPIO) += spi_gpio.o
+ obj-$(CONFIG_SPI_GPIO_OLD) += spi_gpio_old.o
+ obj-$(CONFIG_SPI_IMX) += spi_imx.o
+ obj-$(CONFIG_SPI_LM70_LLP) += spi_lm70llp.o
++obj-$(CONFIG_SPI_PB44) += pb44_spi.o
+ obj-$(CONFIG_SPI_PXA2XX) += pxa2xx_spi.o
+ obj-$(CONFIG_SPI_OMAP_UWIRE) += omap_uwire.o
+ obj-$(CONFIG_SPI_OMAP24XX) += omap2_mcspi.o