aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.32/152-rb4xx-spi-driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-08-31 20:13:47 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-08-31 20:13:47 +0000
commit21ef5a475e2a3475d628141be356182ea2154930 (patch)
treec66acc497fee281492a4775a34cf0c3c7434a70b /target/linux/ar71xx/patches-2.6.32/152-rb4xx-spi-driver.patch
parent1efec5288555df8111dc4bb7766e5261a87d0323 (diff)
downloadupstream-21ef5a475e2a3475d628141be356182ea2154930.tar.gz
upstream-21ef5a475e2a3475d628141be356182ea2154930.tar.bz2
upstream-21ef5a475e2a3475d628141be356182ea2154930.zip
ar71xx: rewrite SPI drivers for the RB4xx boards
* add a new SPI controller driver * add SPI driver for the CPLD chip * convert the NAND driver * enable the mikroSD slot * enable more LEDs git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22863 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.32/152-rb4xx-spi-driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.32/152-rb4xx-spi-driver.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.32/152-rb4xx-spi-driver.patch b/target/linux/ar71xx/patches-2.6.32/152-rb4xx-spi-driver.patch
new file mode 100644
index 0000000000..e7a2124b83
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.32/152-rb4xx-spi-driver.patch
@@ -0,0 +1,25 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -214,6 +214,12 @@ config SPI_PXA2XX
+ The driver can be configured to use any SSP port and additional
+ documentation can be found a Documentation/spi/pxa2xx.
+
++config SPI_RB4XX
++ tristate "Mikrotik RB4XX SPI master"
++ depends on SPI_MASTER && AR71XX_MACH_RB4XX
++ help
++ SPI controller driver for the Mikrotik RB4xx series boards.
++
+ config SPI_S3C24XX
+ tristate "Samsung S3C24XX series SPI"
+ depends on ARCH_S3C2410 && EXPERIMENTAL
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -33,6 +33,7 @@ obj-$(CONFIG_SPI_S3C24XX_GPIO) += spi_s
+ obj-$(CONFIG_SPI_S3C24XX) += spi_s3c24xx.o
+ obj-$(CONFIG_SPI_TXX9) += spi_txx9.o
+ obj-$(CONFIG_SPI_XILINX) += xilinx_spi.o
++obj-$(CONFIG_SPI_RB4XX) += rb4xx_spi.o
+ obj-$(CONFIG_SPI_SH_SCI) += spi_sh_sci.o
+ obj-$(CONFIG_SPI_STMP3XXX) += spi_stmp.o
+ # ... add above this line ...