aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorLech Perczak <lech.perczak@gmail.com>2019-11-17 20:57:10 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-21 14:10:13 +0100
commit1b4b4e3faeac04125540cb0bd24543d94a383784 (patch)
tree63b53b0d78f3314e308f49a330f914af3f2b2ce4 /target/linux/ar71xx/image
parentc1245ebc96c26f3281da9d01932d727dd48f0ad2 (diff)
downloadupstream-1b4b4e3faeac04125540cb0bd24543d94a383784.tar.gz
upstream-1b4b4e3faeac04125540cb0bd24543d94a383784.tar.bz2
upstream-1b4b4e3faeac04125540cb0bd24543d94a383784.zip
ar71xx: ubnt-rocket-m-ti: fix RSSI LED definitions
When mapping for RSSI LEDs was defined for interface wlan0 on Ubiquiti Rocket M Titanium, it missed connection to actual interface. Therefore create the mapping to interface, so RSSI LEDs work without additional configuration, after starting rssileds service. While at that, split RSSI into ~equal intervals for 6 LEDs, and remove coefficients needed for PWM LEDs, as this board does not support PWM LEDs. Finally, for complete support, enable 'rssileds' package in per-device rootfs, so the indicator works out of box. Signed-off-by: Lech Perczak <lech.perczak@gmail.com> (cherry picked from commit 83708f233daceacebd1c49da44711cc87b49162a)
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/generic-ubnt.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/generic-ubnt.mk b/target/linux/ar71xx/image/generic-ubnt.mk
index c155cbd817..8d62980add 100644
--- a/target/linux/ar71xx/image/generic-ubnt.mk
+++ b/target/linux/ar71xx/image/generic-ubnt.mk
@@ -217,6 +217,7 @@ TARGET_DEVICES += ubnt-rocket-m-xw
define Device/ubnt-rocket-m-ti
$(Device/ubnt-xw)
DEVICE_TITLE := Ubiquiti Rocket M TI
+ DEVICE_PACKAGES += rssileds
BOARDNAME := UBNT-RM-TI
UBNT_TYPE := TI
endef