aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-11-08 18:40:37 +0100
committerFelix Fietkau <nbd@nbd.name>2018-02-05 10:15:53 +0100
commitcde71a543c629f63e6f01850fd8b6f3f94cdd25d (patch)
tree61a463012d3958e88e256b27f43e939dfd0b03a0 /target/linux/ar71xx/image
parentecc347dd6e175b23590dc4ddb91344397d3eeb4d (diff)
downloadupstream-cde71a543c629f63e6f01850fd8b6f3f94cdd25d.tar.gz
upstream-cde71a543c629f63e6f01850fd8b6f3f94cdd25d.tar.bz2
upstream-cde71a543c629f63e6f01850fd8b6f3f94cdd25d.zip
build: replace uses of OpenWrt with $(VERSION_DIST)
This makes the distribution name more configurable. Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/generic.mk6
-rw-r--r--target/linux/ar71xx/image/legacy.mk14
2 files changed, 10 insertions, 10 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index b2e701c844..95265d1c0a 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -28,7 +28,7 @@ define Build/mkwrggimg
$(STAGING_DIR_HOST)/bin/mkwrggimg -b \
-i $@ -o $@.imghdr -d /dev/mtdblock/1 \
-m $(BOARDNAME) -s $(DAP_SIGNATURE) \
- -v OpenWrt -B $(REVISION)
+ -v $(VERSION_DIST) -B $(REVISION)
mv $@.imghdr $@
endef
@@ -46,7 +46,7 @@ define Build/netgear-squashfs
-A mips -O linux -T filesystem -C none \
-M $(NETGEAR_KERNEL_MAGIC) \
-a 0xbf070000 -e 0xbf070000 \
- -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+ -n 'MIPS $(VERSION_DIST) Linux-$(LINUX_VERSION)' \
-d $@.squashfs $@
rm -rf $@.squashfs $@.fs
endef
@@ -93,7 +93,7 @@ define Build/uImageHiWiFi
mkimage -A $(LINUX_KARCH) \
-O linux -T kernel \
-C $(1) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
- -n 'tw150v1 $(call toupper,$(LINUX_KARCH)) OpenWrt Linux-$(LINUX_VERSION)' -d $@ $@.new
+ -n 'tw150v1 $(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) Linux-$(LINUX_VERSION)' -d $@ $@.new
@mv $@.new $@
endef
diff --git a/target/linux/ar71xx/image/legacy.mk b/target/linux/ar71xx/image/legacy.mk
index bd8ca2cefe..cbc859dd08 100644
--- a/target/linux/ar71xx/image/legacy.mk
+++ b/target/linux/ar71xx/image/legacy.mk
@@ -87,7 +87,7 @@ ifneq ($(SUBTARGET),mikrotik)
# $(4): output file.
define MkuImage
mkimage -A mips -O linux -T kernel -a 0x80060000 -C $(1) $(2) \
- -e 0x80060000 -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+ -e 0x80060000 -n 'MIPS $(VERSION_DIST) Linux-$(LINUX_VERSION)' \
-d $(3) $(4)
endef
@@ -484,11 +484,11 @@ define Image/Build/Belkin
$(eval rootsize=$(call mtdpartsize,rootfs,$(4)))
$(call Sysupgrade/RKuImage,$(1),$(2),$(kernsize),$(rootsize))
if [ -e "$(call sysupname,$(1),$(2))" ]; then \
- edimax_fw_header -m $(5) -v "$(shell echo -n OpenWrt$(REVISION) | cut -c -13)" \
+ edimax_fw_header -m $(5) -v "$(shell echo -n $(VERSION_DIST)$(REVISION) | cut -c -13)" \
-n "uImage" \
-i $(KDIR_TMP)/vmlinux-$(2).uImage \
-o $(KDIR_TMP)/$(2)-uImage; \
- edimax_fw_header -m $(5) -v "$(shell echo -n OpenWrt$(REVISION) | cut -c -13)" \
+ edimax_fw_header -m $(5) -v "$(shell echo -n $(VERSION_DIST)$(REVISION) | cut -c -13)" \
-n "rootfs" \
-i $(KDIR)/root.$(1) \
-o $(KDIR_TMP)/$(2)-rootfs; \
@@ -661,7 +661,7 @@ define Image/Build/Netgear/buildkernel
) > $(KDIR_TMP)/vmlinux-$(2).uImage.squashfs.tmp2
mkimage -A mips -O linux -T filesystem -C none -M $(5) \
-a 0xbf070000 -e 0xbf070000 \
- -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+ -n 'MIPS $(VERSION_DIST) Linux-$(LINUX_VERSION)' \
-d $(KDIR_TMP)/vmlinux-$(2).uImage.squashfs.tmp2 \
$(KDIR_TMP)/vmlinux-$(2).uImage.squashfs
endef
@@ -673,7 +673,7 @@ define Image/Build/Netgear
for r in $(7) ; do \
[ -n "$$r" ] && dashr="-$$r" || dashr= ; \
$(STAGING_DIR_HOST)/bin/mkdniimg \
- -B $(6) -v OpenWrt.$(REVISION) -r "$$r" $(8) \
+ -B $(6) -v $(VERSION_DIST).$(REVISION) -r "$$r" $(8) \
-i $(call sysupname,$(1),$(2)) \
-o $(call imgname,$(1),$(2))-factory$$dashr.img; \
done; \
@@ -714,7 +714,7 @@ define Image/Build/NetgearNAND/buildkernel
dd if=/dev/zero of=$(KDIR_TMP)/fakeroot-$(2) bs=131072 count=1
mkimage -A mips -O linux -T filesystem -C none \
-a 0xbf070000 -e 0xbf070000 \
- -n 'MIPS OpenWrt fakeroot' \
+ -n 'MIPS $(VERSION_DIST) fakeroot' \
-d $(KDIR_TMP)/fakeroot-$(2) \
-M $(5) \
$(KDIR_TMP)/fakeroot-$(2).uImage
@@ -745,7 +745,7 @@ define Image/Build/NetgearNAND
dd if=$(KDIR_TMP)/$(2)-root.ubi \
) > $(imageraw)
$(STAGING_DIR_HOST)/bin/mkdniimg \
- -B $(6) -v OpenWrt.$(REVISION) -r "$$r" $(8) \
+ -B $(6) -v $(VERSION_DIST).$(REVISION) -r "$$r" $(8) \
-i $(imageraw) \
-o $(call imgname,ubi,$(2))-factory.img