aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorThibaut VARENE <hacks@slashdirt.org>2017-01-04 22:44:54 +0100
committerFelix Fietkau <nbd@nbd.name>2017-02-01 14:59:11 +0100
commitca2a03d1f6fc5288f1f1e9098c317ca9249e50b9 (patch)
tree29f41ea9f5bcd906ff6eef24f8ea353ee42a8ae7 /target/linux/ar71xx/image
parent0656bee36b157c19a248f35999001f48b91c8ec1 (diff)
downloadupstream-ca2a03d1f6fc5288f1f1e9098c317ca9249e50b9.tar.gz
upstream-ca2a03d1f6fc5288f1f1e9098c317ca9249e50b9.tar.bz2
upstream-ca2a03d1f6fc5288f1f1e9098c317ca9249e50b9.zip
ar71xx: add support for RB-941-2nD
Add full support for Mikrotik RB-941-2nD (hAP lite) Original patch by Sergey Sergeev <adron@yapic.net> and more information is available here: https://wiki.openwrt.org/toh/mikrotik/rb941_2nd I updated and adapted the patch to apply cleanly to LEDE trunk and added proper numbering for the switch ports (matching case labels). Tested working on actual hardware with the information provided in the above webpage. Sysupgrade works. Signed-off-by: Thibaut VARENE <hacks@slashdirt.org> Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/mikrotik.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/mikrotik.mk b/target/linux/ar71xx/image/mikrotik.mk
index 000253b622..ff14f90ca6 100644
--- a/target/linux/ar71xx/image/mikrotik.mk
+++ b/target/linux/ar71xx/image/mikrotik.mk
@@ -20,3 +20,22 @@ $(Device/mikrotik)
endef
TARGET_DEVICES += nand-64m nand-large
+
+define Device/rb-nor-flash-16M
+ DEVICE_PROFILE := Default
+ BLOCKSIZE := 64k
+ IMAGE_SIZE := 16000k
+ LOADER_TYPE := elf
+ KERNEL_INSTALL := 1
+ KERNEL := kernel-bin | lzma | loader-kernel | kernel2minor -s 1024 -e
+ KERNEL_INITRAMFS := kernel-bin | lzma | loader-kernel
+ IMAGES := sysupgrade.bin
+ IMAGE/sysupgrade.bin = append-rootfs | pad-rootfs | combined-image | check-size $$$$(IMAGE_SIZE)
+endef
+
+define Device/rb-941-2nd
+$(Device/rb-nor-flash-16M)
+ BOARDNAME:= rb-941-2nd
+endef
+
+TARGET_DEVICES += rb-941-2nd