aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-12-29 19:40:56 +0100
committerMathias Kresin <dev@kresin.me>2018-12-30 20:08:13 +0100
commitde42466528b4e5748d18af9396a4226b0c1cd0fa (patch)
tree6f6dd7a6efaa1f9a92757ecba7b00b6d24cbea8b /target/linux/ar71xx/image
parent7c1332d95fbaea2e0a5029947a2b8d3d43c171b4 (diff)
downloadupstream-de42466528b4e5748d18af9396a4226b0c1cd0fa.tar.gz
upstream-de42466528b4e5748d18af9396a4226b0c1cd0fa.tar.bz2
upstream-de42466528b4e5748d18af9396a4226b0c1cd0fa.zip
ar71xx: sync seama image build code with ramips
Use the same syntax as used in the ramips target, to use common seama recipes. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/generic.mk13
1 files changed, 8 insertions, 5 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 45c6d75399..9f5e755cfe 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -1,4 +1,5 @@
-DEVICE_VARS += DAP_SIGNATURE NETGEAR_BOARD_ID NETGEAR_HW_ID NETGEAR_KERNEL_MAGIC ROOTFS_SIZE SEAMA_SIGNATURE
+DEVICE_VARS += DAP_SIGNATURE NETGEAR_BOARD_ID NETGEAR_HW_ID NETGEAR_KERNEL_MAGIC ROOTFS_SIZE
+DEVICE_VARS += SEAMA_SIGNATURE SEAMA_MTDBLOCK
define Build/alfa-network-rootfs-header
mkimage \
@@ -67,12 +68,14 @@ define Build/relocate-kernel
endef
define Build/seama
- $(STAGING_DIR_HOST)/bin/seama -i $@ $(if $(1),$(1),-m "dev=/dev/mtdblock/1" -m "type=firmware")
+ $(STAGING_DIR_HOST)/bin/seama -i $@ \
+ -m "dev=/dev/mtdblock/$(SEAMA_MTDBLOCK)" -m "type=firmware"
mv $@.seama $@
endef
define Build/seama-seal
- $(call Build/seama,-s $@.seama $(1))
+ $(STAGING_DIR_HOST)/bin/seama -i $@ -s $@.seama \
+ -m "signature=$(SEAMA_SIGNATURE)"
endef
define Build/teltonika-fw-fake-checksum
@@ -1138,6 +1141,7 @@ define Device/seama
KERNEL := kernel-bin | patch-cmdline | relocate-kernel | lzma
KERNEL_INITRAMFS := kernel-bin | patch-cmdline | lzma | seama
KERNEL_INITRAMFS_SUFFIX = $$(KERNEL_SUFFIX).seama
+ SEAMA_MTDBLOCK := 1
IMAGES := sysupgrade.bin factory.bin
# 64 bytes offset:
@@ -1149,8 +1153,7 @@ define Device/seama
check-size $$$$(IMAGE_SIZE)
IMAGE/factory.bin := \
$$(IMAGE/default) | seama | pad-rootfs | \
- seama-seal -m "signature=$$$$(SEAMA_SIGNATURE)" | \
- check-size $$$$(IMAGE_SIZE)
+ seama-seal | check-size $$$$(IMAGE_SIZE)
SEAMA_SIGNATURE :=
endef