aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorHenryk Heisig <hyniu@o2.pl>2017-06-16 15:26:30 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2017-06-29 10:37:36 +0200
commitb05c7193fd289ff697324caccf77adf9ffa76373 (patch)
treee6a96df1048c168ef6f7b3f484a0e5fbaaf27bd9 /target/linux/ar71xx/image
parent01280bc8dc1d9ca089fad7b231d718e166698f4a (diff)
downloadupstream-b05c7193fd289ff697324caccf77adf9ffa76373.tar.gz
upstream-b05c7193fd289ff697324caccf77adf9ffa76373.tar.bz2
upstream-b05c7193fd289ff697324caccf77adf9ffa76373.zip
ar71xx: add support for TP-Link Archer C58 v1
TP-Link Archer C58 v1 is a dual-band AC1350 router, based on Qualcomm QCA9561 + QCA9886. It looks like Archer C59 v1 without USB port. Specification: - 775/650/258 MHz (CPU/DDR/AHB) - 64 MB of RAM (DDR2) - 8 MB of FLASH (SPI NOR) - 3T3R 2.4 GHz - 2T2R 5 GHz - 5x 10/100 Mbps Ethernet - 6x LED, 3x button - UART header on PCB, RX, TX at TP4+5 (backside) QCA9886 wlan needs pre_cal_data file and enable ieee80211 phy hotplug to patch macaddress. Flash instruction: Use "factory" image directly in vendor GUI. Recovery method: 1. Set PC to fixed ip address 192.168.0.66/24. 2. Download "lede-ar71xx-generic-archer-c58-v1-squashfs-factory.bin" and rename it to "tp_recovery.bin". 3. Start a tftp server with the file "tp_recovery.bin" in its root directory. 4. Turn off the router. 5. Press and hold Reset button. 6. Turn on router with the reset button pressed and wait ~15 seconds. 7. Release the reset button and after a short time the firmware should be transferred from the tftp server. 8. Wait ~30 second to complete recovery. Flash instruction under U-Boot, using UART: tftp 0x81000000 lede-ar71xx-...-sysupgrade.bin erase 0x9f020000 +$filesize cp.b $fileaddr 0x9f020000 $filesize reset This commit is based on GitHub PR#1112 Signed-off-by: Henryk Heisig <hyniu@o2.pl>
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/tp-link.mk13
1 files changed, 12 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/tp-link.mk b/target/linux/ar71xx/image/tp-link.mk
index 243c15a858..0979505a78 100644
--- a/target/linux/ar71xx/image/tp-link.mk
+++ b/target/linux/ar71xx/image/tp-link.mk
@@ -137,6 +137,17 @@ define Device/archer-c25-v1
MTDPARTS := spi0.0:128k(factory-uboot)ro,64k(u-boot)ro,1536k(kernel),6272k(rootfs),128k(config)ro,64k(art)ro,7808k@0x30000(firmware)
endef
+define Device/archer-c58-v1
+ $(Device/archer-cxx)
+ DEVICE_TITLE := TP-LINK Archer C58 v1
+ DEVICE_PACKAGES := kmod-ath10k
+ BOARDNAME := ARCHER-C58-V1
+ TPLINK_BOARD_NAME := ARCHER-C58-V1
+ DEVICE_PROFILE := ARCHERC58V1
+ IMAGE_SIZE := 7936k
+ MTDPARTS := spi0.0:64k(u-boot)ro,64k(mac)ro,1344k(kernel),6592k(rootfs),64k(tplink)ro,64k(art)ro,7936k@0x20000(firmware)
+endef
+
define Device/archer-c59-v1
$(Device/archer-cxx)
DEVICE_TITLE := TP-LINK Archer C59 v1
@@ -158,7 +169,7 @@ define Device/archer-c60-v1
IMAGE_SIZE := 7936k
MTDPARTS := spi0.0:64k(u-boot)ro,64k(mac)ro,1344k(kernel),6592k(rootfs),64k(tplink)ro,64k(art)ro,7936k@0x20000(firmware)
endef
-TARGET_DEVICES += archer-c25-v1 archer-c59-v1 archer-c60-v1
+TARGET_DEVICES += archer-c25-v1 archer-c58-v1 archer-c59-v1 archer-c60-v1
define Device/archer-c5-v1
$(Device/tplink-16mlzma)