aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
author张鹏 <sd20@qxwlan.com>2018-07-17 18:11:21 +0800
committerJohn Crispin <john@phrozen.org>2018-07-30 10:43:36 +0200
commitac03d51a3f4daa2f6a2a83f041dcd71674a9f724 (patch)
tree02a91d8c90dfb5b7d8240fd514a4915af5ffacc1 /target/linux/ar71xx/image
parentb74f63f81d6121b5eace3f0c0c87399f7e0fde92 (diff)
downloadupstream-ac03d51a3f4daa2f6a2a83f041dcd71674a9f724.tar.gz
upstream-ac03d51a3f4daa2f6a2a83f041dcd71674a9f724.tar.bz2
upstream-ac03d51a3f4daa2f6a2a83f041dcd71674a9f724.zip
ar71xx:add support for E750A v4
Qxwlan E750A v4 is based on Qualcomm QCA9344. Specification: - 560/450/225 MHz (CPU/DDR/AHB) - 128 MB of RAM (DDR2) - 8/16 MB of FLASH (SPI NOR) - 2T2R 5G GHz (AR9344) - 2x 10/100 Mbps Ethernet (one port with PoE support) - 1x miniPCIe slot (USB 2.0 bus only) - 7x LED (6 driven by GPIO) - 1x button (reset) - 1x DC jack for main power input (9-48 V) - UART (J23) and LEDs (J2) headers on PCB Flash instruction (using U-Boot CLI and tftp server): - Configure PC with static IP 192.168.1.10 and tftp server. - Rename "sysupgrade" filename to "firmware.bin" and place it in tftp server directory. - Connect PC with one of RJ45 ports, power up the board and press "enter" key to access U-Boot CLI. - Use the following command to update the device to OpenWrt: "run lfw". Flash instruction (using U-Boot web-based recovery): - Configure PC with static IP 192.168.1.xxx(2-254)/24. - Connect PC with one of RJ45 ports, press the reset button, power up the board and keep button pressed for around 6-7 seconds, until LEDs start flashing. - Open your browser and enter 192.168.1.1, select "sysupgrade" image and click the upgrade button. Signed-off-by: 张鹏 <sd20@qxwlan.com>
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/generic.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index dedc19d52c..d9da3be782 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -384,6 +384,25 @@ define Device/e600gac-v2-8M
endef
TARGET_DEVICES += e600gac-v2-8M
+define Device/e750a-v4-16M
+ DEVICE_TITLE := Qxwlan E750A v4 (16MB flash)
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 -swconfig
+ BOARDNAME := E750A-V4
+ SUPPORTED_DEVICES := e750a-v4
+ IMAGE_SIZE := 15936k
+ MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env),64k(pri-data)ro,64k(art),-(firmware)
+ IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) |\
+ append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += e750a-v4-16M
+
+define Device/e750a-v4-8M
+ $(Device/e750a-v4-16M)
+ DEVICE_TITLE := Qxwlan E750A v4 (8MB flash)
+ IMAGE_SIZE := 7744k
+endef
+TARGET_DEVICES += e750a-v4-8M
+
define Device/ew-balin
DEVICE_TITLE := Embedded Wireless Balin Platform
DEVICE_PACKAGES := kmod-usb-core kmod-usb-chipidea