aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-10-11 16:24:10 +0000
committerJohn Crispin <john@openwrt.org>2015-10-11 16:24:10 +0000
commitabe9f6b0256cf55a5d92ab26e8e2ec0afd83bb5e (patch)
tree6165827b2a4b574ee921862f2dacdfc5b2ad3253 /target/linux/ar71xx/image
parentb2e3f71b7c5dfa3a341d9d5b0f630ada89bad69d (diff)
downloadupstream-abe9f6b0256cf55a5d92ab26e8e2ec0afd83bb5e.tar.gz
upstream-abe9f6b0256cf55a5d92ab26e8e2ec0afd83bb5e.tar.bz2
upstream-abe9f6b0256cf55a5d92ab26e8e2ec0afd83bb5e.zip
ar71xx/image: remove old build step TPLINK-LZMA
all boards has been migrated to the new build step Signed-off-by: Alexander Couzens <lynxis@fe80.eu> SVN-Revision: 47177
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile29
1 files changed, 1 insertions, 28 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 6c84a39164..f63c734989 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -1002,7 +1002,7 @@ endef
SINGLE_PROFILES:=
-# $(1) : name of image build method to be used, e.g., TPLINK-LZMA, AthLzma.
+# $(1) : name of image build method to be used, e.g., AthLzma.
# $(2) : name of the build template to be used, e.g. 64k, 64kraw, 128k, etc.
# $(3) : name of the profile to be defined.
# $(4) : board name.
@@ -1780,33 +1780,6 @@ define Image/Build/TPLINK/initramfs
endef
-Image/Build/TPLINK-LZMA/buildkernel=$(call PatchKernelLzma,$(2),$(3))
-
-define Image/Build/TPLINK-LZMA
- -$(STAGING_DIR_HOST)/bin/mktplinkfw \
- -H $(4) -W $(5) -F $(6) -N OpenWrt -V $(REVISION) $(7) \
- -X 0x40000 \
- -k $(KDIR_TMP)/vmlinux-$(2).bin.lzma \
- -r $(KDIR)/root.$(1) \
- -a $(call rootfs_align,$(1)) -j \
- -o $(call factoryname,$(1),$(2))
- -$(STAGING_DIR_HOST)/bin/mktplinkfw \
- -H $(4) -W $(5) -F $(6) -N OpenWrt -V $(REVISION) $(7) -s \
- -X 0x40000 \
- -k $(KDIR_TMP)/vmlinux-$(2).bin.lzma \
- -r $(KDIR)/root.$(1) \
- -a $(call rootfs_align,$(1)) -j \
- -o $(call sysupname,$(1),$(2))
-endef
-
-define Image/Build/TPLINK-LZMA/initramfs
- $(call PatchKernelLzma,$(2),$(3),,-initramfs)
- -$(STAGING_DIR_HOST)/bin/mktplinkfw -c \
- -H $(4) -W $(5) -F $(6) -N OpenWrt -V $(REVISION) $(7) -s \
- -k $(KDIR_TMP)/vmlinux-initramfs-$(2).bin.lzma \
- -o $(call imgname,$(1),$(2))-uImage.bin
-endef
-
Image/Build/TPLINK-64K/buildkernel=$(call PatchKernelLzma,$(2),$(3))
define Image/Build/TPLINK-64K