aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorKeith Maika <keithm@aoeex.com>2018-06-15 00:39:09 -0400
committerJohn Crispin <john@phrozen.org>2018-07-30 14:04:45 +0200
commit4caab808300ad75575d778bae6e184caa26aeabc (patch)
tree787765d5401038139b55a77be6e88172e30742f9 /target/linux/ar71xx/image
parenta3d2448fae5499356a31d71585a812ac65e7a39a (diff)
downloadupstream-4caab808300ad75575d778bae6e184caa26aeabc.tar.gz
upstream-4caab808300ad75575d778bae6e184caa26aeabc.tar.bz2
upstream-4caab808300ad75575d778bae6e184caa26aeabc.zip
ar71xx: add support for TP-Link Archer C59 v2
TP-Link Archer C59v2 is a dual-band AC1350 router based on Qualcomm/Atheros QCA9561+QCA9886 chips. Specification: - 775/650/258 MHz (CPU/DDR/AHB) - 128 MB of RAM (DDR2) - 16 MB of FLASH (SPI NOR) - 3T3R 2.4 GHz - 2T2R 5 GHz - 5x 10/100 Mbps Ethernet - USB 2.0 port - UART header on PCB Flash instruction: - via web UI: 1. Download openwrt-ar71xx-generic-archer-c59-v2-squashfs-factory.bin 2. Login to router and open the Advanced tab 3. Navigate to System Tools -> Firmware Upgrade 4. Upload firmware using the Manual Upgrade form - via TFTP: 1. Set PC to fixed ip address 192.168.0.66 2. Download openwrt-ar71xx-generic-archer-c59-v2-squashfs-factory.bin and rename it to tp_recovery.bin 3. Start a tftp server with the file tp_recovery.bin in its root directory 4. Turn off the router 5. Press and hold Reset button 6. Turn on router with the reset button pressed and wait ~15 seconds 7. Release the reset button and after a short time the firmware should be transferred from the tftp server 8. Wait ~30 second to complete recovery. Signed-off-by: Keith Maika <keithm@aoeex.com>
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/generic-tp-link.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/generic-tp-link.mk b/target/linux/ar71xx/image/generic-tp-link.mk
index 89983779e7..3c0a89d2b8 100644
--- a/target/linux/ar71xx/image/generic-tp-link.mk
+++ b/target/linux/ar71xx/image/generic-tp-link.mk
@@ -45,6 +45,18 @@ define Device/archer-c59-v1
endef
TARGET_DEVICES += archer-c59-v1
+define Device/archer-c59-v2
+ $(Device/archer-c59-v1)
+ DEVICE_TITLE := TP-LINK Archer C59 v2
+ BOARDNAME := ARCHER-C59-V2
+ TPLINK_BOARD_ID := ARCHER-C59-V2
+ DEVICE_PROFILE := ARCHERC59V2
+ IMAGE_SIZE := 14400k
+ MTDPARTS := spi0.0:128k(factory-boot)ro,64k(u-boot)ro,64k(mac)ro,14400k(firmware),1664k(tplink)ro,64k@0xff0000(art)ro
+ SUPPORTED_DEVICES := archer-c59-v2
+endef
+TARGET_DEVICES += archer-c59-v2
+
define Device/archer-c60-v1
$(Device/archer-cxx)
DEVICE_TITLE := TP-LINK Archer C60 v1