aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorPau Escrich <p4u@dabax.net>2018-01-12 16:36:25 +0100
committerDaniel Golle <daniel@makrotopia.org>2018-11-15 19:49:51 +0100
commit15f16bf05b8441aed0e0c6000740996b75724ac1 (patch)
tree497db6a28495edfdf3d0d144e711e63ddc4157ad /target/linux/ar71xx/image
parentc6a1bcac16f92afa1e41eaceafc85075d97a74cd (diff)
downloadupstream-15f16bf05b8441aed0e0c6000740996b75724ac1.tar.gz
upstream-15f16bf05b8441aed0e0c6000740996b75724ac1.tar.bz2
upstream-15f16bf05b8441aed0e0c6000740996b75724ac1.zip
ar71xx: add support for Gainstrong MiniBox V3.2
Adds MiniBox V3.2 ar71xx target (QCA99531 + QCA9887) Info: http://oolite.cn/minibox-v3-2-qca9531-qca9887-module-pin-specification.html Reference patch: http://oolite.cn/wp-content/uploads/2017/09/minibox_v3_cc15.05_20160325.patch Installation: Upload firmware to uboot via HTTP at 192.168.1.1 (press button for 5 seconds) Signed-off-by: Pau Escrich <p4u@dabax.net> Signed-off-by: Daniel Golle <daniel@makrotopia.org> (daniel@makrotopia.org: rebased and fixed conflicts, fixed LED name, added ath10k eeprom)
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/generic.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 269865af92..18f0379845 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -895,6 +895,16 @@ define Device/minibox-v1
endef
TARGET_DEVICES += minibox-v1
+define Device/minibox-v3.2
+ $(Device/tplink-16mlzma)
+ DEVICE_TITLE := Gainstrong MiniBox V3.2
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport kmod-ath10k ath10k-firmware-qca9887 -swconfig
+ BOARDNAME := MINIBOX-V3.2
+ DEVICE_PROFILE := MINIBOXV32
+ TPLINK_HWID := 0x3C00010C
+endef
+TARGET_DEVICES += minibox-v3.2
+
define Device/oolite-v1
$(Device/minibox-v1)
DEVICE_TITLE := GainStrong Oolite V1.0