aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-06-18 18:21:23 +0000
committerJohn Crispin <john@openwrt.org>2015-06-18 18:21:23 +0000
commite85f3471bad00a51711e7d7c7ab84e4ba64c1b93 (patch)
tree4ee2bf6587ffc618a167a9b55ca97eeb7cf4eb64 /target/linux/ar71xx/image
parent8399be545a01b05549902a96778b9b3983a6b4ec (diff)
downloadupstream-e85f3471bad00a51711e7d7c7ab84e4ba64c1b93.tar.gz
upstream-e85f3471bad00a51711e7d7c7ab84e4ba64c1b93.tar.bz2
upstream-e85f3471bad00a51711e7d7c7ab84e4ba64c1b93.zip
ar71xx: add support for TL-WR720N-v4.
The hardware should be almost the same as TL-WR720N-v3. WiFi and LAN networks were tested by "Lo Yuk Fai <loyukfai@gmail.com>". Failsafe and slider switch were tested by "Wong min <alpha080@gmail.com>". Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com> SVN-Revision: 46046
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 57c58ace79..3483ee40bf 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -492,7 +492,15 @@ define Device/tl-wr720n-v3
TPLINK_HWID := 0x07200103
CONSOLE := ttyATH0,115200
endef
-TARGET_DEVICES += tl-wr703n-v1 tl-wr710n-v1 tl-wr710n-v2 tl-wr720n-v3
+
+define Device/tl-wr720n-v4
+ $(Device/tplink-4mlzma)
+ BOARDNAME := TL-WR720N-v3
+ DEVICE_PROFILE := TLWR720
+ TPLINK_HWID := 0x07200104
+ CONSOLE := ttyATH0,115200
+endef
+TARGET_DEVICES += tl-wr703n-v1 tl-wr710n-v1 tl-wr710n-v2 tl-wr720n-v3 tl-wr720n-v4
define Device/tl-wr740n-v4
$(Device/tplink-4mlzma)