aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-11-24 18:30:19 +0000
committerJohn Crispin <john@openwrt.org>2015-11-24 18:30:19 +0000
commita04c3e73a33f9effc77511076bdbf8a0013a9574 (patch)
tree8f4879679d34a9a37aafe7f556abf0c14257f49f /target/linux/ar71xx/image
parent72093bd5284e25cb1b7ffc649c8d6a63fd8dcb83 (diff)
downloadupstream-a04c3e73a33f9effc77511076bdbf8a0013a9574.tar.gz
upstream-a04c3e73a33f9effc77511076bdbf8a0013a9574.tar.bz2
upstream-a04c3e73a33f9effc77511076bdbf8a0013a9574.zip
ar71xx: add GL-AR300 support V3
This is the patch for GL-AR300 V3, tested against the latest trunk. Signed-off-by: alzhao<alzhao@gmail.com> SVN-Revision: 47621
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index bb97764df2..e0eea98560 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -196,6 +196,15 @@ define Device/gl-ar150
endef
TARGET_DEVICES += gl-ar150
+define Device/gl-ar300
+ BOARDNAME = GL-AR300
+ IMAGE_SIZE = 16000k
+ CONSOLE = ttyS0,115200
+ MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,16000k(firmware),64k(art)ro
+endef
+TARGET_DEVICES += gl-ar300
+
+
define Device/wndr3700
BOARDNAME = WNDR3700
NETGEAR_KERNEL_MAGIC = 0x33373030