aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-08 20:39:18 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-08 20:39:18 +0000
commit7f75961e381540aa0434a12732908475de946cdf (patch)
treea2deb4249a6922f183fb95533d337a9380aefc4f /target/linux/ar71xx/image
parent1d6a530fe6a129814fc93a45df01a01342569be8 (diff)
downloadupstream-7f75961e381540aa0434a12732908475de946cdf.tar.gz
upstream-7f75961e381540aa0434a12732908475de946cdf.tar.bz2
upstream-7f75961e381540aa0434a12732908475de946cdf.zip
ar71xx: add support for TP-LINK TL-WR941ND v6 (international version)
The international version is completely different from the already supported Chinese version. The WLAN of the QCA956x SoC used by this router has been fixed in r46948. This patch looks like it changes a lot in 700-MIPS-ath79-openwrt-machines.patch; that is not the case. Unfortunately, quilt decided to completely reorganize the Kconfig patch even though only a single section has been added. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net> SVN-Revision: 47420
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 09e5394fd9..11cf7165c3 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -774,6 +774,13 @@ define Device/tl-wr941nd-v5
TPLINK_HWID := 0x09410005
endef
+define Device/tl-wr941nd-v6
+ $(Device/tplink-4mlzma)
+ BOARDNAME := TL-WR941ND-v6
+ DEVICE_PROFILE := TLWR941
+ TPLINK_HWID := 0x09410006
+endef
+
# Chinese version (unlike European) is similar to the TL-WDR3500
define Device/tl-wr941nd-v6-cn
$(Device/tplink-4mlzma)
@@ -781,7 +788,7 @@ define Device/tl-wr941nd-v6-cn
DEVICE_PROFILE := TLWR941
TPLINK_HWID := 0x09410006
endef
-TARGET_DEVICES += tl-wr941nd-v2 tl-wr941nd-v3 tl-wr941nd-v4 tl-wr941nd-v5 tl-wr941nd-v6-cn
+TARGET_DEVICES += tl-wr941nd-v2 tl-wr941nd-v3 tl-wr941nd-v4 tl-wr941nd-v5 tl-wr941nd-v6 tl-wr941nd-v6-cn
define Device/tl-wr1041n-v2
$(Device/tplink-4mlzma)