aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-07-07 13:46:38 +0000
committerJohn Crispin <john@openwrt.org>2015-07-07 13:46:38 +0000
commit6fc2e94120d0ec05562afed64a3a92c447a9f2fd (patch)
treeef6ccb37260aa489313bc57ca26590f52d69d67b /target/linux/ar71xx/image
parentf8eaad100bbb3ae17f079a42154a4dd26ea376fb (diff)
downloadupstream-6fc2e94120d0ec05562afed64a3a92c447a9f2fd.tar.gz
upstream-6fc2e94120d0ec05562afed64a3a92c447a9f2fd.tar.bz2
upstream-6fc2e94120d0ec05562afed64a3a92c447a9f2fd.zip
ar71xx: add support for ubnt rocket-m ti
rocket-m titanium is a device based on ar9344 with 802.11af poe. It doesn't use the SoC wifi, instead it's using an ar9280 connected to the pci bus. The gps version of the rocket-m ti is working, but gps is untested. The gps is connected to the first serial port. Signed-off-by: Alexander Couzens <lynxis@fe80.eu> SVN-Revision: 46234
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 53ce56bbd2..3c052424bd 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -787,7 +787,14 @@ define Device/ubnt-rocket-m-xw
$(Device/ubnt-xw)
BOARDNAME := UBNT-RM-XW
endef
-TARGET_DEVICES += ubnt-nano-m-xw ubnt-loco-m-xw ubnt-rocket-m-xw
+
+define Device/ubnt-rocket-m-ti
+ $(Device/ubnt-xw)
+ BOARDNAME := UBNT-RM-TI
+ UBNT_TYPE := TI
+ UBNT_BOARD := XM
+endef
+TARGET_DEVICES += ubnt-nano-m-xw ubnt-loco-m-xw ubnt-rocket-m-xw ubnt-rocket-m-ti
define Device/ubnt-air-gateway
$(Device/ubnt-xm)