aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-07-24 09:09:49 +0000
committerJohn Crispin <john@openwrt.org>2015-07-24 09:09:49 +0000
commit5cd49bb067cadfeba6eb7f09982f76558101ad5d (patch)
tree2fdede7b056dcf9982ef82ad5d03cf362c1742ba /target/linux/ar71xx/image
parentb98205c946a89861563c402167a954e2caa13603 (diff)
downloadupstream-5cd49bb067cadfeba6eb7f09982f76558101ad5d.tar.gz
upstream-5cd49bb067cadfeba6eb7f09982f76558101ad5d.tar.bz2
upstream-5cd49bb067cadfeba6eb7f09982f76558101ad5d.zip
ar71xx: add support for Onion Omega
This patch adds support for the Onion Omega. https://onion.io/omega Signed-off-by: L. D. Pinney <ldpinney@gmail.com> Acked-by: Boken Lin <bl@onion.io> Tested-by: Jacky Huang <huangfangcheng@163.com> SVN-Revision: 46458
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index e7d22f6395..c2ebb8f0d3 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -388,6 +388,15 @@ define Device/mc-mac1200r
endef
TARGET_DEVICES += mc-mac1200r
+define Device/onion-omega
+ $(Device/tplink-16mlzma)
+ BOARDNAME := ONION-OMEGA
+ DEVICE_PROFILE := OMEGA
+ TPLINK_HWID := 0x04700001
+ CONSOLE := ttyATH0,115200
+endef
+TARGET_DEVICES += onion-omega
+
define Device/tl-mr10u-v1
$(Device/tplink-4mlzma)
BOARDNAME := TL-MR10U