aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-07-07 13:46:54 +0000
committerJohn Crispin <john@openwrt.org>2015-07-07 13:46:54 +0000
commit055663201b7ce579815ec1cd23424237aede5134 (patch)
tree49c47adec24bfb6b00c03a2b573ef21d9f72b8bb /target/linux/ar71xx/image
parent9f2b8b3902c38dfd68db74a4c235c7f38f177822 (diff)
downloadupstream-055663201b7ce579815ec1cd23424237aede5134.tar.gz
upstream-055663201b7ce579815ec1cd23424237aede5134.tar.bz2
upstream-055663201b7ce579815ec1cd23424237aede5134.zip
ar71xx: Add Support for the Bitmain Antminer S3
This patch adds support for the Bitmain Antminer S3 Cryptocurrency Miner http://wiki.openwrt.org/toh/bitmain/s3 Signed-off-by: L. D. Pinney <ldpinney@gmail.com> SVN-Revision: 46236
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 3c052424bd..018385dabf 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -338,6 +338,14 @@ define Device/antminer-s1
CONSOLE := ttyATH0,115200
endef
+define Device/antminer-s3
+ $(Device/tplink-8mlzma)
+ BOARDNAME := ANTMINER-S3
+ DEVICE_PROFILE := ANTMINER_S3
+ TPLINK_HWID := 0x04440003
+ CONSOLE := ttyATH0,115200
+endef
+
define Device/el-m150
$(Device/tplink-8mlzma)
BOARDNAME := EL-M150
@@ -353,7 +361,7 @@ define Device/el-mini
TPLINK_HWID := 0x01530001
CONSOLE := ttyATH0,115200
endef
-TARGET_DEVICES += antminer-s1 el-m150 el-mini
+TARGET_DEVICES += antminer-s1 antminer-s3 el-m150 el-mini
define Device/gl-inet-6408A-v1
$(Device/tplink-8mlzma)