aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2018-05-29 17:00:53 +0200
committerJohn Crispin <john@phrozen.org>2018-06-07 09:31:58 +0200
commite36f8b3f3980903d5cefc51fe274c19c7a0719f2 (patch)
tree9b3a86a9d695efc09b565dcf88f14dbe28da7253 /target/linux/ar71xx/image
parenta84962ea35e4e97f1c4a42f2eac0242cc2cbd879 (diff)
downloadupstream-e36f8b3f3980903d5cefc51fe274c19c7a0719f2.tar.gz
upstream-e36f8b3f3980903d5cefc51fe274c19c7a0719f2.tar.bz2
upstream-e36f8b3f3980903d5cefc51fe274c19c7a0719f2.zip
ar71xx: add support for OCEDO Koala
This commit adds support for the OCEDO Koala SOC: Qualcomm QCA9558 (Scorpion) RAM: 128MB FLASH: 16MiB WLAN1: QCA9558 2.4 GHz 802.11bgn 3x3 WLAN2: QCA9880 5 GHz 802.11nac 3x3 INPUT: RESET button LED: Power, LAN, WiFi 2.4, WiFi 5, SYS Serial: Header Next to Black metal shield Pinout is 3.3V - GND - TX - RX (Arrow Pad is 3.3V) The Serial setting is 115200-8-N-1. Tested and working: - Ethernet - 2.4 GHz WiFi - 5 GHz WiFi - TFTP boot from ramdisk image - Installation via ramdisk image - OpenWRT sysupgrade - Buttons - LEDs Installation seems to be possible only through booting an OpenWRT ramdisk image. Hold down the reset button while powering on the device. It will load a ramdisk image named 'koala-uImage-initramfs-lzma.bin' from 192.168.100.8. Note: depending on the present software, the device might also try to pull a file called 'koala-uimage-factory'. Only the name differs, it is still used as a ramdisk image. Wait for the ramdisk image to boot. OpenWRT can be written to the flash via sysupgrade or mtd. Due to the flip-flop bootloader which we not (yet) support, you need to set the partition the bootloader is selecting. It is possible from the initramfs image with > fw_setenv bootcmd run bootcmd_1 Afterwards you can reboot the device. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/generic-senao.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/generic-senao.mk b/target/linux/ar71xx/image/generic-senao.mk
index 3a7f6776b3..f5473126dd 100644
--- a/target/linux/ar71xx/image/generic-senao.mk
+++ b/target/linux/ar71xx/image/generic-senao.mk
@@ -26,3 +26,16 @@ define Device/ens202ext
IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
endef
TARGET_DEVICES += ens202ext
+
+define Device/koala
+ DEVICE_TITLE := OCEDO Koala
+ BOARDNAME := KOALA
+ DEVICE_PACKAGES := kmod-ath10k ath10k-firmware-qca988x
+ KERNEL_SIZE := 1536k
+ IMAGE_SIZE := 7424k
+ MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env),1536k(kernel),5888k(rootfs),1536k(kernel2),5888k(rootfs2),1088k(data)ro,64k(id)ro,64k(art)ro,7424k@0x50000(firmware)
+ KERNEL := kernel-bin | patch-cmdline | lzma | uImage lzma
+ KERNEL_INITRAMFS := $$(KERNEL)
+ IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += koala