aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorCatrinel Catrinescu <cc@80211.de>2018-01-15 16:45:16 +0100
committerFelix Fietkau <nbd@nbd.name>2018-01-25 16:50:08 +0100
commit4ba2dd130a9dbec584d1b4616d00b28237d8777c (patch)
treea870887a159659b0bca16eca8342fb265ab4bc85 /target/linux/ar71xx/image
parentad4232e3e986d89ac49f01bb2cec44d1e66d6969 (diff)
downloadupstream-4ba2dd130a9dbec584d1b4616d00b28237d8777c.tar.gz
upstream-4ba2dd130a9dbec584d1b4616d00b28237d8777c.tar.bz2
upstream-4ba2dd130a9dbec584d1b4616d00b28237d8777c.zip
ar71xx: add ew-balin platform from Embedded Wireless
Add the Embedded Wireless "Balin" platform SoC: QCA AR9344 or AR9350 RAM: DDR2-RAM 64MBytes Flash: SPI-NOR 16MBytes WLAN: 2 x 2 MIMO 2.4 & 5 GHz IEEE802.11 a/b/g/n Ethernet: 3 x 10/100 Mb/s USB: 1 x USB2.0 Host/Device bootstrap-pin at power-up PCI-Express: 1 x lane PCIe 1.2 UART: 1 x Normal, 1 x High-Speed JTAG: 1 x EJTAG GPIO: 10 x Input/Output multiplexed The module comes already with the current vanilla OpenWrt firmware. To update, use "sysupgrade" image directly in vendor firmware. Signed-off-by: Catrinel Catrinescu <cc@80211.de>
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/generic.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 88b9f930b6..b2e701c844 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -272,6 +272,15 @@ define Device/dragino2
endef
TARGET_DEVICES += dragino2
+define Device/ew-balin
+ DEVICE_TITLE := Embedded Wireless Balin Platform
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb-chipidea
+ BOARDNAME = EW-BALIN
+ IMAGE_SIZE = 16000k
+ MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env),16000k(firmware),64k(art)ro
+endef
+TARGET_DEVICES += ew-balin
+
define Device/ew-dorin
DEVICE_TITLE := Embedded Wireless Dorin Platform
DEVICE_PACKAGES := kmod-usb-core kmod-usb-chipidea