aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-06-27 23:26:03 +0200
committerFelix Fietkau <nbd@nbd.name>2017-10-19 12:27:42 +0200
commit2c9aff289e71689c07770efb2ce9e5f1b30960f2 (patch)
treed75f00e22eeaed547c8ec3d4b323404ed3ee708c /target/linux/ar71xx/image
parent2af10c30fe5a7f1d13a790187868c1ee2209a575 (diff)
downloadupstream-2c9aff289e71689c07770efb2ce9e5f1b30960f2.tar.gz
upstream-2c9aff289e71689c07770efb2ce9e5f1b30960f2.tar.bz2
upstream-2c9aff289e71689c07770efb2ce9e5f1b30960f2.zip
ar71xx: add support for Nokia WI2A-AC200i
Specifications: - SoC: Qualcomm QCA9558 (720 MHz) - RAM: 256MB - Storage: 1MB NOR, 128 MB NAND flash - Ethernet: 1x1000M Installation: 1. Connect to serial console on the board 2. Boot initramfs image over u-boot 3. Copy image to the device and run sysupgrade Installation without serial console is not supported at this time Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/nand.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/nand.mk b/target/linux/ar71xx/image/nand.mk
index fafccb9b77..ba9e1ba622 100644
--- a/target/linux/ar71xx/image/nand.mk
+++ b/target/linux/ar71xx/image/nand.mk
@@ -84,6 +84,21 @@ define Device/rambutan
endef
TARGET_DEVICES += rambutan
+define Device/wi2a-ac200i
+ SUPPORTED_DEVICES = $(1)
+ DEVICE_TITLE := Nokia WI2A-AC200i
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-ath9k kmod-ath10k ath10k-firmware-qca988x
+ BOARDNAME := WI2A-AC200i
+ BLOCKSIZE := 64k
+ KERNEL_SIZE := 3648k
+ IMAGE_SIZE := 32m
+ IMAGES := sysupgrade.tar
+ MTDPARTS := spi0.0:256k(u-boot)ro,64k(envFacA)ro,64k(envFacB)ro,64k(ART)ro,128k(u-boot-env)
+ KERNEL := kernel-bin | patch-cmdline | lzma | uImage lzma
+ IMAGE/sysupgrade.tar := sysupgrade-tar | append-metadata
+endef
+TARGET_DEVICES += wi2a-ac200i
+
define Device/z1
DEVICE_TITLE := Meraki Z1
DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport kmod-spi-gpio kmod-ath9k kmod-owl-loader