aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-09-16 08:31:40 +0000
committerJohn Crispin <john@openwrt.org>2015-09-16 08:31:40 +0000
commit1297679f4bbd47000d3ee36ed0f09efd7c581e76 (patch)
tree640c892d7b4930c7c8a836af2013810d521dd745 /target/linux/ar71xx/image
parent08e0621f4e59c5e7c2c381223d051cb0000b1707 (diff)
downloadupstream-1297679f4bbd47000d3ee36ed0f09efd7c581e76.tar.gz
upstream-1297679f4bbd47000d3ee36ed0f09efd7c581e76.tar.bz2
upstream-1297679f4bbd47000d3ee36ed0f09efd7c581e76.zip
ar71xx: Add UBNT airGateway Pro support
This patch adds kernel and userspace support for the Ubiquiti Networks airGateway Pro. Signed-off-by: Matthew Reeve <mreeve at tenxnetworks.com> SVN-Revision: 46961
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 0becd24857..a8b8ecb8be 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -883,6 +883,15 @@ define Device/ubnt-air-gateway
endef
TARGET_DEVICES += ubnt-air-gateway
+define Device/ubnt-air-gateway-pro
+ $(Device/ubnt-xm)
+ BOARDNAME := UBNT-AGWP
+ UBNT_TYPE := AirGWP
+ UBNT_CHIP := ar934x
+ CONSOLE = ttyS0,115200
+endef
+TARGET_DEVICES += ubnt-air-gateway-pro
+
define Device/ubdev01
$(Device/ubnt-xm)
MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,7488k(firmware),64k(certs),256k(cfg)ro,64k(EEPROM)ro