aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorThibaut VARENE <hacks@slashdirt.org>2017-02-15 11:40:06 +0100
committerFelix Fietkau <nbd@nbd.name>2017-02-22 22:52:20 +0100
commitf6a52bf3374682475e92c1960c19df8e6c1ea9b2 (patch)
treefab3799d76c561a1c4ab490c8febb7a3e07574dd /target/linux/ar71xx/image
parent53c862705dc04b6a499c2ed47158bcc20954184c (diff)
downloadupstream-f6a52bf3374682475e92c1960c19df8e6c1ea9b2.tar.gz
upstream-f6a52bf3374682475e92c1960c19df8e6c1ea9b2.tar.bz2
upstream-f6a52bf3374682475e92c1960c19df8e6c1ea9b2.zip
ar71xx: Enable mtdsplit support for RB SPI NOR devices
This patch enables mtdsplit for the MikroTik subtarget. It converts mach-rbspi.c to use a single "firmware" partition. Finally, it converts the SPI NOR profile to metadata images: the original combined-image format is gone, the images are now "standard" sysupgrade images with metadata appended. Note: kernel2minor apparently pads the kernel container to erase-block boundary, but this is undocumented behaviour, so we do not rely on it and call pad-to anyway. Note: in platform.sh, the boards are tested last in platform_check_image() as this should eventually become the "*)" default case when more devices switch to metadata images. Signed-off-by: Thibaut VARENE <hacks@slashdirt.org>
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/mikrotik.mk9
1 files changed, 4 insertions, 5 deletions
diff --git a/target/linux/ar71xx/image/mikrotik.mk b/target/linux/ar71xx/image/mikrotik.mk
index c7cf15d061..9338e5f916 100644
--- a/target/linux/ar71xx/image/mikrotik.mk
+++ b/target/linux/ar71xx/image/mikrotik.mk
@@ -27,14 +27,13 @@ TARGET_DEVICES += nand-64m nand-large
define Device/rb-nor-flash-16M
DEVICE_TITLE := MikroTik RouterBoard with 16 MB SPI NOR flash
DEVICE_PACKAGES := rbcfg
- BLOCKSIZE := 64k
IMAGE_SIZE := 16000k
LOADER_TYPE := elf
KERNEL_INSTALL := 1
- KERNEL := kernel-bin | lzma | loader-kernel | kernel2minor -s 1024 -e
- KERNEL_INITRAMFS := kernel-bin | lzma | loader-kernel
- IMAGES := sysupgrade.bin
- IMAGE/sysupgrade.bin = append-rootfs | pad-rootfs | combined-image | check-size $$$$(IMAGE_SIZE)
+ KERNEL := kernel-bin | lzma | loader-kernel
+ SUPPORTED_DEVICES := rb-750-r2 rb-750up-r2 rb-941-2nd rb-951ui-2nd rb-mapl-2nd
+ IMAGE/sysupgrade.bin = append-kernel | kernel2minor -s 1024 -e | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
endef
TARGET_DEVICES += rb-nor-flash-16M