aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorRoger Pueyo Centelles <roger.pueyo@guifi.net>2018-01-08 12:55:05 +0100
committerDaniel Golle <daniel@makrotopia.org>2018-01-15 04:14:18 +0100
commite15c63a37574bd15ce3a6636c2f04741ab76f7b9 (patch)
treef389bc1d76d099cf78be91cc3612faa60b0cfadb /target/linux/ar71xx/image
parent20e68f6d395d72ca8a5d5ec364bc7cf4c1862b87 (diff)
downloadupstream-e15c63a37574bd15ce3a6636c2f04741ab76f7b9.tar.gz
upstream-e15c63a37574bd15ce3a6636c2f04741ab76f7b9.tar.bz2
upstream-e15c63a37574bd15ce3a6636c2f04741ab76f7b9.zip
ar71xx: add support for MikroTik RouterBOARD wAP G-5HacT2HnD (wAP AC)
This patch adds support for the MikroTik RouterBOARD wAP G-5HacT2HnD (wAP AC), a small weatherproof dual band, dual-radio 802.11ac wireless AP with integrated omnidirectional anntennae and one 10/100/1000 Mbps Ethernet ports. See https://mikrotik.com/product/RBwAPG-5HacT2HnD for more info. Specifications: - SoC: Qualcomm Atheros QCA9556 - RAM: 64 MB - Storage: 16 MB NOR - Wireless: · Atheros AR9550 (SoC) 802.11b/g/n 2x2:2, 2 dBi antennae · Qualcomm QCA9880 802.11a/n/ac 3x3:3, 2 dBi antennae - Ethernet: Atheros AG71xx (SoC, AR8033), 1x 1000/100/10 port, passive PoE in Working: - Board/system detection - Sysupgrade - Serial console - Ethernet - 2.4 GHz radio - 5 GHz radio - Reset button Not working: - LEDs (added according to Mikrotik's GPL sources but not functional) Unsupported: - ZT2046Q SPI temperature and voltage sensor Contributors: Giuseppe Tipaldi (@Ciusss89) Ricky (@rickydee) Signed-off-by: Roger Pueyo Centelles <roger.pueyo@guifi.net> Signed-off-by: Daniel Golle <daniel@makrotopia.org> [daniel@makrotopia.org: whitespace fix, use PHYADDR instead of PHYMASK]
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/mikrotik.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/mikrotik.mk b/target/linux/ar71xx/image/mikrotik.mk
index fd6ca27938..403bcb08b5 100644
--- a/target/linux/ar71xx/image/mikrotik.mk
+++ b/target/linux/ar71xx/image/mikrotik.mk
@@ -50,5 +50,6 @@ define Device/rb-nor-flash-16M-ac
$(Device/rb-nor-flash-16M)
DEVICE_TITLE := MikroTik RouterBoard (16 MB SPI NOR, 802.11ac)
DEVICE_PACKAGES += kmod-ath10k ath10k-firmware-qca988x ath10k-firmware-qca9887
+ SUPPORTED_DEVICES := rb-wapg-5hact2hnd
endef
TARGET_DEVICES += rb-nor-flash-16M-ac