aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2017-11-14 12:15:03 +0100
committerPiotr Dymacz <pepe2k@gmail.com>2017-11-14 22:36:46 +0100
commitac4a52b5c80fd877503251a299f7ca6f1cc394e6 (patch)
tree331bb14f74c6ed53073304b9db7b1623b89f84da /target/linux/ar71xx/image
parentd7adaceda33b0b94962477e4c06c04d1ea4e82f8 (diff)
downloadupstream-ac4a52b5c80fd877503251a299f7ca6f1cc394e6.tar.gz
upstream-ac4a52b5c80fd877503251a299f7ca6f1cc394e6.tar.bz2
upstream-ac4a52b5c80fd877503251a299f7ca6f1cc394e6.zip
ar71xx: complete support for RB mAP 2nD
This patch adds support for the MikroTik RouterBOARD mAP 2nD https://mikrotik.com/product/RBmAP2nD Specifications: - SoC: Qualcomm QCA9531 (650 MHz) - RAM: 64 MB - Storage: 16 MB NOR SPI flash - Wireless: builtin QCA9531, 2x2:2 - Ethernet: 2x100M (802.3af/at POE in and passive POE out on ETH2) - USB: microUSB type AB port This patch adds missing code to fully support mAP. Machfile already contained configuration for mAP 2nD, but device specific configuration like LEDs etc., was missing. Note: The POE LED works but doesn't turn on when POE passthrough is enabled, despite being configured with GPIO trigger. Installation 1. Login to the Mikrotik WebUI to backup your licence keys 2. Setup a DHCP/BOOTP server with: - DHCP-Option 66 (TFTP server name) pointing to a local TFTP server within the same subnet of the DHCP range - DHCP-Option 67 (Bootfile-Name) matching the initramfs filename of the to be booted image 3. Connect the port labeled internet to your local network 4. Keep the reset button pushed down and power on the board The board should load and start the initramfs image from the TFTP server. Login as root/without password to the started LEDE via SSH listing on IPv4 address 192.168.1.1. Use sysupgrade to install LEDE. Revert to RouterOS Use the "rbcfg" package on in LEDE: - rbcfg set boot_protocol bootp - rbcfg set boot_device ethnand - rbcfg apply Open Netinstall and reboot routerboard. Now Netinstall sees RouterBOARD and you can install RouterOS. If NetInstall gets stuck on Sending offer just wait for it to timeout and then close and open Netinstall again. Click on install again. In order for RouterOS to function properly, you need to restore license for the device. You can do that by including license in NetInstall. Signed-off-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/mikrotik.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/mikrotik.mk b/target/linux/ar71xx/image/mikrotik.mk
index 5ee3eee65e..46d2a3e3a6 100644
--- a/target/linux/ar71xx/image/mikrotik.mk
+++ b/target/linux/ar71xx/image/mikrotik.mk
@@ -25,12 +25,12 @@ TARGET_DEVICES += nand-64m nand-large
define Device/rb-nor-flash-16M
DEVICE_TITLE := MikroTik RouterBoard (16 MB SPI NOR)
- DEVICE_PACKAGES := rbcfg rssileds -nand-utils
+ DEVICE_PACKAGES := rbcfg rssileds -nand-utils kmod-ledtrig-gpio
IMAGE_SIZE := 16000k
LOADER_TYPE := elf
KERNEL_INSTALL := 1
KERNEL := kernel-bin | lzma | loader-kernel
- SUPPORTED_DEVICES := rb-750-r2 rb-750up-r2 rb-750p-pbr2 rb-941-2nd rb-951ui-2nd rb-952ui-5ac2nd rb-962uigs-5hact2hnt rb-lhg-5nd rb-mapl-2nd rb-wap-2nd
+ SUPPORTED_DEVICES := rb-750-r2 rb-750up-r2 rb-750p-pbr2 rb-941-2nd rb-951ui-2nd rb-952ui-5ac2nd rb-962uigs-5hact2hnt rb-lhg-5nd rb-map-2nd rb-mapl-2nd rb-wap-2nd
IMAGE/sysupgrade.bin := append-kernel | kernel2minor -s 1024 -e | pad-to $$$$(BLOCKSIZE) | \
append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
endef