aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorFederico Cappon <dududede371@gmail.com>2017-06-09 15:11:39 +0000
committerPiotr Dymacz <pepe2k@gmail.com>2017-06-29 10:37:36 +0200
commit9fec39a03388677ce5c8e56de8f049391b8c4ed7 (patch)
tree2179c1fb5b8bd3dc235b279185f44ce4032cf402 /target/linux/ar71xx/image
parent656ed7544fb625756ed8969927b976b0e0120ecb (diff)
downloadupstream-9fec39a03388677ce5c8e56de8f049391b8c4ed7.tar.gz
upstream-9fec39a03388677ce5c8e56de8f049391b8c4ed7.tar.bz2
upstream-9fec39a03388677ce5c8e56de8f049391b8c4ed7.zip
ar71xx: add support for TP-Link TL-WA855RE v1
TP-Link TL-WA855RE v1 is a wall-plug N300 Wi-Fi range extender, based on Qualcomm/Atheros QCA9533 v2. Short specification: - 550/397/198 MHz (CPU/DDR/AHB) - 1x 10/100 Mbps Ethernet - 32 MB of RAM (DDR1) - 4 MB of FLASH - 2T2R 2.4 GHz - 2x external antennas - 2x LED (green and orange in the same package), 2x button - UART: TP5(TX) and TP4(RX) test points on PCB Flash instruction: use "factory" image directly in vendor GUI. Warning: this device does not include any kind of recovery mechanism in the bootloader and disassembling process is not trivial. You can access vendor firmware over serial line using: - login: root - password: sohoadmin Image was tested only in EU version of the device, but should work also with the same device version sold in other countries. Signed-off-by: Federico Cappon <dududede371@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/tp-link.mk25
1 files changed, 19 insertions, 6 deletions
diff --git a/target/linux/ar71xx/image/tp-link.mk b/target/linux/ar71xx/image/tp-link.mk
index a9c3cdd961..243c15a858 100644
--- a/target/linux/ar71xx/image/tp-link.mk
+++ b/target/linux/ar71xx/image/tp-link.mk
@@ -496,18 +496,31 @@ define Device/tl-wa850re-v1
TPLINK_HWID := 0x08500001
endef
-define Device/tl-wa850re-v2
+define Device/tl-wa85xre
$(Device/tplink)
+ KERNEL := kernel-bin | patch-cmdline | lzma | mktplinkfw-kernel
+ IMAGE/sysupgrade.bin := append-rootfs | tplink-safeloader sysupgrade
+ IMAGE/factory.bin := append-rootfs | tplink-safeloader factory
+ MTDPARTS := spi0.0:128k(u-boot)ro,1344k(kernel),2304k(rootfs),256k(config)ro,64k(art)ro,3648k@0x20000(firmware)
+endef
+
+define Device/tl-wa850re-v2
+ $(Device/tl-wa85xre)
DEVICE_TITLE := TP-LINK TL-WA850RE v2
DEVICE_PACKAGES := rssileds
BOARDNAME := TL-WA850RE-V2
DEVICE_PROFILE := TLWA850
TPLINK_BOARD_NAME := TLWA850REV2
TPLINK_HWID := 0x08500002
- KERNEL := kernel-bin | patch-cmdline | lzma | mktplinkfw-kernel
- IMAGE/sysupgrade.bin := append-rootfs | tplink-safeloader sysupgrade
- IMAGE/factory.bin := append-rootfs | tplink-safeloader factory
- MTDPARTS := spi0.0:128k(u-boot)ro,1344k(kernel),2304k(rootfs),256k(config)ro,64k(art)ro,3648k@0x20000(firmware)
+endef
+
+define Device/tl-wa855re-v1
+ $(Device/tl-wa85xre)
+ DEVICE_TITLE := TP-LINK TL-WA855RE v1
+ BOARDNAME := TL-WA855RE-v1
+ DEVICE_PROFILE := TLWA855RE
+ TPLINK_HWID := 0x08550001
+ TPLINK_BOARD_NAME := TLWA855REV1
endef
define Device/tl-wa860re-v1
@@ -517,7 +530,7 @@ define Device/tl-wa860re-v1
DEVICE_PROFILE := TLWA860
TPLINK_HWID := 0x08600001
endef
-TARGET_DEVICES += tl-wa801nd-v1 tl-wa801nd-v2 tl-wa801nd-v3 tl-wa830re-v1 tl-wa830re-v2 tl-wa850re-v1 tl-wa850re-v2 tl-wa860re-v1
+TARGET_DEVICES += tl-wa801nd-v1 tl-wa801nd-v2 tl-wa801nd-v3 tl-wa830re-v1 tl-wa830re-v2 tl-wa850re-v1 tl-wa850re-v2 tl-wa855re-v1 tl-wa860re-v1
define Device/tl-wa901nd-v1
$(Device/tplink-4m)