aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2018-02-15 23:15:53 +0100
committerPiotr Dymacz <pepe2k@gmail.com>2018-02-22 18:53:22 +0100
commit8c64824576598117958691853de68bf4dcfc3c06 (patch)
tree5b89f50f6d9acd9f846def27271ce4b0e9651cb2 /target/linux/ar71xx/image
parent907d67491068890e27f7611da5c5c4d44a672c3c (diff)
downloadupstream-8c64824576598117958691853de68bf4dcfc3c06.tar.gz
upstream-8c64824576598117958691853de68bf4dcfc3c06.tar.bz2
upstream-8c64824576598117958691853de68bf4dcfc3c06.zip
ar71xx: add support for GainStrong Oolite V5.2
GainStrong Oolite V5.2 is a small (39.5 x 78 mm), dual-band system on module, based on Qualcomm QCA9531 + QCA9887. All QCA9531 SOC GPIOs are available on castellated pins. Specification: - 650/400/200 MHz (CPU/DDR/AHB) - 64/128 MB of RAM (DDR2) - 16 MB of FLASH (SPI NOR) - 5x 10/100 Mbps Ethernet (all ports available on castellated pins) - 2T2R 2.4 GHz (QCA9531), with ext. PA and LNA - 1T1R 5 GHz (QCA9887) with ext. FEM (SKY85710-11) - 3x U.FL - 1x USB 2.0 The dedicated development board includes 5 FE ports, USB 2.0 port, two buttons (one directly connected to SOC reset input), header with all GPIOs and several LEDs. Flash instruction: Vendor firmware is based on OpenWrt. LuCI or sysupgrade can be used to flash OpenWrt firmware. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/generic.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index e1cd21d9cf..37231e0228 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -852,6 +852,25 @@ define Device/oolite-v1
endef
TARGET_DEVICES += oolite-v1
+define Device/oolite-v5.2
+ $(Device/tplink-16mlzma)
+ DEVICE_TITLE := GainStrong Oolite V5.2
+ DEVICE_PACKAGES := ath10k-firmware-qca9887 kmod-ath10k kmod-usb-core kmod-usb2
+ BOARDNAME := OOLITE-V5-2
+ DEVICE_PROFILE := OOLITEV52
+ TPLINK_HWID := 0x3C00010B
+ IMAGES := sysupgrade.bin
+endef
+TARGET_DEVICES += oolite-v5.2
+
+define Device/oolite-v5.2-dev
+ $(Device/oolite-v5.2)
+ DEVICE_TITLE := GainStrong Oolite V5.2-Dev (development board)
+ BOARDNAME := OOLITE-V5-2-DEV
+ DEVICE_PROFILE := OOLITEV52DEV
+endef
+TARGET_DEVICES += oolite-v5.2-dev
+
define Device/omy-g1
$(Device/tplink-16mlzma)
DEVICE_TITLE := OMYlink OMY-G1