aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorMarty Plummer <ntzrmtthihu777@gmail.com>2017-04-14 12:08:17 -0500
committerPiotr Dymacz <pepe2k@gmail.com>2017-05-30 14:15:25 +0200
commit558d86923e3f5a62577036aa2bace2532163ca13 (patch)
tree01947ffaa9ab4341c6719e9fbd452b68f61a8cfa /target/linux/ar71xx/image
parent0f21873f7f1465f9ddd0ebde11716b966cb7665e (diff)
downloadupstream-558d86923e3f5a62577036aa2bace2532163ca13.tar.gz
upstream-558d86923e3f5a62577036aa2bace2532163ca13.tar.bz2
upstream-558d86923e3f5a62577036aa2bace2532163ca13.zip
ar71xx: add support for EnGenius ENS202EXT
EnGenius ENS202EXT is an outdoor wireless access point with 2-port 10/100 switch, detachable antennas and proprietery PoE. The device is based on Qualcomm/Atheros AR9341 v1. Specifications: - 535/400/200 MHz (CPU/DDR/AHB) - 64 MB of RAM - 16 MB of FLASH - UART (J1) header on PCB (unpopulated) - 2x 10/100 Mbps Ethernet - 2.4 GHz, up to 26dBm - 2x external, detachable antennas - 7x LED, 1x button Flash instructions: You have three options: - Use the vendor firmware upgrade page on the web interface and give it the factory.img. This is the easiest way to go about it. - If you have serial access during u-boot, interrupt the normal boot (any key before timeout) and run 'run failsafe_boot'; this will bring you to a minimal openwrt luci image on ip 192.168.1.1 useful if you've bricked the normal firmware. - Use the vendor's management cli, which can be accessed via telnet with the same credentials as the web login (default admin:admin), then issue the following commands: *** Hi admin, welcome to use cli(V-1.6.7) *** ---========= Commands Help =========--- stat -- Status sys -- System wless2 -- 2.4G-Wireless mgmt -- Management tree -- Tree help -- Help reboot -- Reboot ens202ext>mgmt Management ---========= Commands Help =========--- admin -- Administration mvlan -- Management VLAN settings snmp -- SNMP settings backup -- Backup/Restore settings autorb -- Auto reboot settings fwgrade -- Firmware upgrade time -- Time settings wifisch -- Wifi schedule log -- Log diag -- Diagnostics disc -- Device Discovery logout -- Logout help -- Help exit -- Exit ens202ext/mgmt>fwgrade Management --> Firmware upgrade ---========= Commands Help =========--- fwup -- Firmware upgrade help -- Help exit -- Exit ens202ext/mgmt/fwgrade>fwup http://web.server/lede-ar71xx-generic-ens202ext-squashfs-factory.bin Signed-off-by: Marty Plummer <ntzrmtthihu777@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile1
-rw-r--r--target/linux/ar71xx/image/senao.mk26
2 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 8eac5fc997..32951e5347 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -17,6 +17,7 @@ include ./tp-link.mk
include ./ubnt.mk
include ./generic.mk
include ./legacy-devices.mk
+include ./senao.mk
endif
ifeq ($(SUBTARGET),nand)
include ./nand.mk
diff --git a/target/linux/ar71xx/image/senao.mk b/target/linux/ar71xx/image/senao.mk
new file mode 100644
index 0000000000..50d3ccdfe1
--- /dev/null
+++ b/target/linux/ar71xx/image/senao.mk
@@ -0,0 +1,26 @@
+define Build/senao-factory-image
+ $(eval board=$(word 1,$(1)))
+ $(eval rootfs=$(word 2,$(1)))
+
+ mkdir -p $@.senao
+
+ touch $@.senao/FWINFO-OpenWrt-$(REVISION)-$(board)
+ $(CP) $(IMAGE_KERNEL) $@.senao/openwrt-senao-$(board)-uImage-lzma.bin
+ $(CP) $(rootfs) $@.senao/openwrt-senao-$(board)-root.squashfs
+
+ $(TAR) -czf $@ -C $@.senao .
+ rm -rf $@.senao
+endef
+
+define Device/ens202ext
+ DEVICE_TITLE := EnGenius ENS202EXT
+ BOARDNAME := ENS202EXT
+ DEVICE_PACKAGES += rssileds
+ KERNEL_SIZE := 1536k
+ KERNEL := kernel-bin | patch-cmdline | lzma | uImage lzma | check-size $$(KERNEL_SIZE)
+ IMAGE_SIZE := 12096k
+ IMAGES += factory.bin
+ IMAGE/factory.bin/squashfs := append-rootfs | pad-rootfs | senao-factory-image ens202ext $$$$@
+ MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env),320k(custom)ro,13632k(firmware),2048k(failsafe)ro,64k(art)ro
+endef
+TARGET_DEVICES += ens202ext