aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorPaul Wassi <p.wassi@gmx.at>2017-10-22 22:39:30 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2017-11-14 22:36:46 +0100
commite202a8b9f6ecf02d42da4781dc5e27abe957f7dc (patch)
tree2c467e826793f68350d0cf9156407785ea3f9770 /target/linux/ar71xx/image
parentac4a52b5c80fd877503251a299f7ca6f1cc394e6 (diff)
downloadupstream-e202a8b9f6ecf02d42da4781dc5e27abe957f7dc.tar.gz
upstream-e202a8b9f6ecf02d42da4781dc5e27abe957f7dc.tar.bz2
upstream-e202a8b9f6ecf02d42da4781dc5e27abe957f7dc.zip
ar71xx: add support for TP-Link TL-WA901ND v5
The TL-WA901ND v5 has the same hardware as v4, although the PCB has a different layout. Installation from factory is done via TFTP. (rename -factory image to wa901ndv4_tp_recovery.bin for tftp) Signed-off-by: Paul Wassi <p.wassi@gmx.at>
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/tp-link.mk9
1 files changed, 8 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/tp-link.mk b/target/linux/ar71xx/image/tp-link.mk
index 18c50cf20f..c3cfdb9f47 100644
--- a/target/linux/ar71xx/image/tp-link.mk
+++ b/target/linux/ar71xx/image/tp-link.mk
@@ -574,7 +574,14 @@ define Device/tl-wa901nd-v4
TPLINK_HWID := 0x09010004
IMAGE/factory.bin := append-rootfs | mktplinkfw factory -C EU
endef
-TARGET_DEVICES += tl-wa901nd-v1 tl-wa901nd-v2 tl-wa901nd-v3 tl-wa901nd-v4
+
+define Device/tl-wa901nd-v5
+ $(Device/tl-wa901nd-v4)
+ DEVICE_TITLE := TP-LINK TL-WA901N/ND v5
+ BOARDNAME := TL-WA901ND-v5
+ TPLINK_HWID := 0x09010005
+endef
+TARGET_DEVICES += tl-wa901nd-v1 tl-wa901nd-v2 tl-wa901nd-v3 tl-wa901nd-v4 tl-wa901nd-v5
define Device/tl-wdr3320-v2
$(Device/tplink-4mlzma)