aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-07 21:00:47 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-11 13:09:21 +0100
commitb1dbe6028eed57a89ae94c5e61e0b1e65f3aeb80 (patch)
treeb14cff59ff4b6711a4d220adcdefda2169287ef5 /target/linux/ar71xx/image
parent1b17f4f2609b822ce1225bb205794085072097c7 (diff)
downloadupstream-b1dbe6028eed57a89ae94c5e61e0b1e65f3aeb80.tar.gz
upstream-b1dbe6028eed57a89ae94c5e61e0b1e65f3aeb80.tar.bz2
upstream-b1dbe6028eed57a89ae94c5e61e0b1e65f3aeb80.zip
ar71xx: fix legacy image build error
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/legacy.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/legacy.mk b/target/linux/ar71xx/image/legacy.mk
index 32590166b9..f80b700be8 100644
--- a/target/linux/ar71xx/image/legacy.mk
+++ b/target/linux/ar71xx/image/legacy.mk
@@ -199,7 +199,7 @@ define Image/BuildLoader
LZMA_TEXT_START=0x80a00000 LOADADDR=0x80060000 \
LOADER_DATA="$(KDIR)/vmlinux$(5).bin.lzma" BOARD="$(1)" \
compile loader.$(2)
- -$(CP) $(KDIR)/loader-$(1).$(2) $(KDIR)/loader-$(1)$(5).$(2)
+ -$(if $(5),$(CP) $(KDIR)/loader-$(1).$(2) $(KDIR)/loader-$(1)$(5).$(2))
endef
#