aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-09-27 08:59:53 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-09-27 08:59:53 +0000
commita7bb7dd99ebe9fcdcc6fb3152eaa830a302d5028 (patch)
treebf3766d8eb911b06f2fdd299ff90dfece2bfafe1 /target/linux/ar71xx/image
parenta41b1df07b7f8fb6500647c5934e394dd1628ea5 (diff)
downloadupstream-a7bb7dd99ebe9fcdcc6fb3152eaa830a302d5028.tar.gz
upstream-a7bb7dd99ebe9fcdcc6fb3152eaa830a302d5028.tar.bz2
upstream-a7bb7dd99ebe9fcdcc6fb3152eaa830a302d5028.zip
Add support for Atheros AP96 reference board
This is still preliminary and not really tested much. Anyway, this version seems to be enough to get both wired and wireless interfaces working. Buttons and leds are also working. mach-ap96.c is based on mach-wndr3700.c. Signed-off-by: Jouni Malinen <jouni.malinen@atheros.com> SVN-Revision: 23125
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 718b7e3ad1..3fa49ba36e 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -571,6 +571,10 @@ define Image/Build/Profile/WNDR3700
$(call Image/Build/Template/$(fs_64k)/$(1),WNDR3700,wndr3700,board=WNDR3700)
endef
+define Image/Build/Profile/AP96
+ $(call Image/Build/Template/$(fs_64k)/$(1),AP83,ap96,board=AP96)
+endef
+
define Image/Build/Profile/WRT400N
$(call Image/Build/Template/$(fs_64k)/$(1),WRT400N,wrt400n,board=WRT400N)
endef
@@ -623,6 +627,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/UBNT,$(1))
$(call Image/Build/Profile/WP543,$(1))
$(call Image/Build/Profile/WNDR3700,$(1))
+ $(call Image/Build/Profile/AP96,$(1))
$(call Image/Build/Profile/WRT400N,$(1))
$(call Image/Build/Profile/WRT160NL,$(1))
$(call Image/Build/Profile/WZRHPG300NH,$(1))