aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-06-18 18:21:05 +0000
committerJohn Crispin <john@openwrt.org>2015-06-18 18:21:05 +0000
commit694dd581ebb2898854385e40655c5cd2a44424c3 (patch)
tree648e8b4eb12198dd43d81275e573f371fc545eed /target/linux/ar71xx/image
parentcf1fb25e670b8b303a4507a5f42f544a12559136 (diff)
downloadupstream-694dd581ebb2898854385e40655c5cd2a44424c3.tar.gz
upstream-694dd581ebb2898854385e40655c5cd2a44424c3.tar.bz2
upstream-694dd581ebb2898854385e40655c5cd2a44424c3.zip
ar71xx: Add Support for the Bitmain Antminer S1
This patch adds support for the Bitmain Antminer S1 Cryptocurrency Miner http://wiki.openwrt.org/toh/bitmain/s1 Signed-off-by: L. D. Pinney <ldpinney@gmail.com> Acked-by: James Hilliard <james.hilliard1@gmail.com> SVN-Revision: 46044
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 0e46194e75..5a82b7caf0 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -330,6 +330,14 @@ define Device/archer-c7-v2
endef
TARGET_DEVICES += archer-c5 archer-c7-v1 archer-c7-v2
+define Device/antminer-s1
+ $(Device/tplink-8mlzma)
+ BOARDNAME := ANTMINER-S1
+ DEVICE_PROFILE := ANTMINER_S1
+ TPLINK_HWID := 0x04440001
+ CONSOLE := ttyATH0,115200
+endef
+
define Device/el-m150
$(Device/tplink-8mlzma)
BOARDNAME := EL-M150
@@ -345,7 +353,7 @@ define Device/el-mini
TPLINK_HWID := 0x01530001
CONSOLE := ttyATH0,115200
endef
-TARGET_DEVICES += el-m150 el-mini
+TARGET_DEVICES += antminer-s1 el-m150 el-mini
define Device/gl-inet-6408A-v1
$(Device/tplink-8mlzma)