aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2017-01-05 16:01:17 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2017-01-05 16:01:17 +0100
commit1fef80f29cf6bdfcb6cdbd913b9147797b8bc218 (patch)
treea050829f38982ad570f0407444ffbd9668e1e4f0 /target/linux/ar71xx/image
parent2ee3e8dd42272f4109830cd26a7fd6f1231ddae8 (diff)
downloadupstream-1fef80f29cf6bdfcb6cdbd913b9147797b8bc218.tar.gz
upstream-1fef80f29cf6bdfcb6cdbd913b9147797b8bc218.tar.bz2
upstream-1fef80f29cf6bdfcb6cdbd913b9147797b8bc218.zip
ar71xx: add support for TP-Link WBS210/510
The devices are mostly identical to the CPE210/510, but use external antennas. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/tp-link.mk18
1 files changed, 17 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/tp-link.mk b/target/linux/ar71xx/image/tp-link.mk
index c6c9b5093c..480d9ad39d 100644
--- a/target/linux/ar71xx/image/tp-link.mk
+++ b/target/linux/ar71xx/image/tp-link.mk
@@ -117,7 +117,23 @@ $(Device/cpe510-520)
BOARDNAME := CPE210
TPLINK_BOARD_NAME := CPE210
endef
-TARGET_DEVICES += cpe210-220 cpe510-520
+
+define Device/wbs210
+$(Device/cpe510-520)
+ DEVICE_TITLE := TP-LINK WBS210
+ DEVICE_PACKAGES := rssileds
+ BOARDNAME := WBS210
+ TPLINK_BOARD_NAME := WBS210
+endef
+
+define Device/wbs510
+$(Device/cpe510-520)
+ DEVICE_TITLE := TP-LINK WBS510
+ DEVICE_PACKAGES := rssileds
+ BOARDNAME := WBS510
+ TPLINK_BOARD_NAME := WBS510
+endef
+TARGET_DEVICES += cpe210-220 cpe510-520 wbs210 wbs510
define Device/re450
DEVICE_TITLE := TP-LINK RE450