aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@googlemail.com>2016-10-05 14:53:11 +0200
committerJohn Crispin <john@phrozen.org>2016-10-15 11:36:50 +0200
commit098f7156cc68d07a8eed9574c76b90c7ade77026 (patch)
tree57d71f1eef6e8fa33320a617dee42309ebbf41c3 /target/linux/ar71xx/image
parente9455c561d4af68840421e3d442e4ad5ebfbedc6 (diff)
downloadupstream-098f7156cc68d07a8eed9574c76b90c7ade77026.tar.gz
upstream-098f7156cc68d07a8eed9574c76b90c7ade77026.tar.bz2
upstream-098f7156cc68d07a8eed9574c76b90c7ade77026.zip
ar71xx: add support for the Airtight C-60
This patch adds support for the Airtight C-60. SOC: Atheros AR9344 rev 2 (CPU:560.000MHz) RAM: 128 MiB NOR: MX25L3205D 4MiB NAND: ST Micro NAND 32MiB 3,3V 8-bit SW-NET: AR8327N (2 Ports) WLAN1: Dual-Band AR9340 Rev:2 (built-in SoC) WLAN2: Dual-Band AR9300 Rev:4 PCIe Chip The switch is setup for an accesspoint: LAN1: (gigabit) is the wan-port. LAN2: (fast ethernet) is bridged with the br-lan. Flashing Guide (via initramfs): 1. Connect a PC to the serial port of the C-60. power up the C-60. Enter u-boot command prompt: #> nand erase #> setenv bootcmd "bootm 0x9f060000" #> saveenv #> setenv ipaddr 192.168.1.1 #> setenv netmask 255.255.255.0 #> setenv serverip 192.168.1.100 #> setenv bootfile lede-ar71xx-nand-c-60-initramfs-kernel.bin #> tftpboot #> bootm 2. Wait for the C-60 to boot LEDE. On the root prompt. Enter: # ubiformat /dev/mtd4 # ubiattach -p /dev/mtd4 3. After that copy the sysupgrade.tar onto the router and run: # sysupgrade sysupgrade.tar to flash the image. Special thanks to Chris Blake <chrisrblake93@gmail.com>. He provided a C-60 unit and he helped with debugging the switch, LEDs and platfrom support. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/nand.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/nand.mk b/target/linux/ar71xx/image/nand.mk
index aa431ac18c..c08081b28e 100644
--- a/target/linux/ar71xx/image/nand.mk
+++ b/target/linux/ar71xx/image/nand.mk
@@ -1,3 +1,18 @@
+define Device/c-60
+ DEVICE_TITLE := AirTight C-60
+ DEVICE_PACKAGES := kmod-spi-gpio kmod-usb-core kmod-usb2 kmod-ath9k
+ BOARDNAME = C-60
+ BLOCKSIZE := 64k
+ KERNEL_SIZE = 3648k
+ IMAGE_SIZE = 32m
+ IMAGES := sysupgrade.tar
+ MTDPARTS = spi0.0:256k(u-boot)ro,128k(u-boot-env)ro,3648k(kernel),64k(art)ro;ar934x-nfc:32m(ubi)
+ KERNEL := kernel-bin | patch-cmdline | lzma | uImage lzma
+ IMAGE/sysupgrade.tar := sysupgrade-tar
+endef
+
+TARGET_DEVICES += c-60
+
define Build/MerakiNAND
-$(STAGING_DIR_HOST)/bin/mkmerakifw \
-B $(BOARDNAME) -s \