aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-08-03 10:22:33 +0000
committerJohn Crispin <blogic@openwrt.org>2015-08-03 10:22:33 +0000
commite443f119e1ea0e77e0d5c4531fe838dd2f431cb1 (patch)
treec8dae7d7be6e1abe11d535bb5702c64e5a12df64 /target/linux/ar71xx/image
parentf732c67f8e0dbd67e4016e47facd7217be01d6d3 (diff)
downloadupstream-e443f119e1ea0e77e0d5c4531fe838dd2f431cb1.tar.gz
upstream-e443f119e1ea0e77e0d5c4531fe838dd2f431cb1.tar.bz2
upstream-e443f119e1ea0e77e0d5c4531fe838dd2f431cb1.zip
ar71xx: Backport support for Onion Omega
Backport of r46458 to CC https://onion.io/omega Signed-off-by: L. D. Pinney <ldpinney@gmail.com> Acked-by: Boken Lin <bl@onion.io> Tested-by: Jacky Huang <huangfangcheng@163.com> git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@46548 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 8276c843a3..b279d8f218 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -337,6 +337,15 @@ define Device/mc-mac1200r
endef
TARGET_DEVICES += mc-mac1200r
+define Device/onion-omega
+ $(Device/tplink-16mlzma)
+ BOARDNAME := ONION-OMEGA
+ DEVICE_PROFILE := OMEGA
+ TPLINK_HWID := 0x04700001
+ CONSOLE := ttyATH0,115200
+endef
+TARGET_DEVICES += onion-omega
+
define Device/tl-mr10u-v1
$(Device/tplink-4mlzma)
BOARDNAME := TL-MR10U