aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-06-18 20:24:15 +0000
committerJohn Crispin <blogic@openwrt.org>2015-06-18 20:24:15 +0000
commit3df0da9819e0e5bb9faa1afec6d5eb0be8e156e9 (patch)
treeff4904243d466e263236886ada31dfd67ca1ad0f /target/linux/ar71xx/image
parente8f2f57bd1a9450d5ffb00018a6f703c2a53614b (diff)
downloadupstream-3df0da9819e0e5bb9faa1afec6d5eb0be8e156e9.tar.gz
upstream-3df0da9819e0e5bb9faa1afec6d5eb0be8e156e9.tar.bz2
upstream-3df0da9819e0e5bb9faa1afec6d5eb0be8e156e9.zip
ar71xx: Add Support for the Bitmain Antminer S1
This patch adds support for the Bitmain Antminer S1 Cryptocurrency Miner http://wiki.openwrt.org/toh/bitmain/s1 Signed-off-by: L. D. Pinney <ldpinney@gmail.com> Acked-by: James Hilliard <james.hilliard1@gmail.com> Backport of r46044 git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@46054 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 187fdb60ae..0b753bd4f9 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -279,6 +279,14 @@ define Device/archer-c7-v2
endef
TARGET_DEVICES += archer-c5 archer-c7-v1 archer-c7-v2
+define Device/antminer-s1
+ $(Device/tplink-8mlzma)
+ BOARDNAME := ANTMINER-S1
+ DEVICE_PROFILE := ANTMINER_S1
+ TPLINK_HWID := 0x04440001
+ CONSOLE := ttyATH0,115200
+endef
+
define Device/el-m150
$(Device/tplink-8mlzma)
BOARDNAME := EL-M150
@@ -294,7 +302,7 @@ define Device/el-mini
TPLINK_HWID := 0x01530001
CONSOLE := ttyATH0,115200
endef
-TARGET_DEVICES += el-m150 el-mini
+TARGET_DEVICES += antminer-s1 el-m150 el-mini
define Device/gl-inet-6408A-v1
$(Device/tplink-8mlzma)