aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-10-19 10:19:44 +0000
committerJohn Crispin <blogic@openwrt.org>2015-10-19 10:19:44 +0000
commit25eee465a964fd5f2b9d01d5baec7105b23a2a03 (patch)
tree63e5b0902144e9f8612687453bf952fcc263d988 /target/linux/ar71xx/image
parent874e0061cec6b2a32d259077fb1789c00bf07833 (diff)
downloadupstream-25eee465a964fd5f2b9d01d5baec7105b23a2a03.tar.gz
upstream-25eee465a964fd5f2b9d01d5baec7105b23a2a03.tar.bz2
upstream-25eee465a964fd5f2b9d01d5baec7105b23a2a03.zip
ar71xx: Add support for WeIO board
Support for WeIO board (http://we-io.net), backported from Designated Driver trunk. Signed-off-by: Drasko DRASKOVIC <drasko.draskovic@gmail.com> Backport of r47110 git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@47232 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 8b7b91f8b8..dfc711480a 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -136,6 +136,14 @@ define Device/carambola2
endef
TARGET_DEVICES += carambola2
+define Device/weio
+ BOARDNAME = WEIO
+ IMAGE_SIZE = 16000k
+ CONSOLE = ttyATH0,115200
+ MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,16000k(firmware),64k(art)ro
+endef
+TARGET_DEVICES += weio
+
define Device/wndr3700
BOARDNAME = WNDR3700
NETGEAR_KERNEL_MAGIC = 0x33373030