aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-11-25 09:51:25 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-11-25 09:51:25 +0000
commit7b4990c9ec8204bea4b57853233268bdab0aebbf (patch)
tree28cdaf51121398faa63c8c542a8a14b104a0e4d7 /target/linux/ar71xx/image
parent816fe4f2ae20de30d5072523d5cbfb865a4db93a (diff)
downloadupstream-7b4990c9ec8204bea4b57853233268bdab0aebbf.tar.gz
upstream-7b4990c9ec8204bea4b57853233268bdab0aebbf.tar.bz2
upstream-7b4990c9ec8204bea4b57853233268bdab0aebbf.zip
ar71xx: create combined images for the RS, RS-PRO and LS-SR71 boards, and add sysupgrade support for them
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18531 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 24b1fa36aa..30663f12cb 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -161,7 +161,11 @@ define Image/Build/UBNT
-B $(4) -v $(5).$(6).OpenWrt.$(REVISION) \
-k $(KDIR)/vmlinux-$(2).lzma \
-r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
- -o $(call imgname,$(1),$(2)).bin
+ -o $(call imgname,$(1),$(2))-factory.bin
+ -sh $(TOPDIR)/scripts/combined-image.sh \
+ "$(KDIR)/vmlinux-$(2).lzma" \
+ "$(BIN_DIR)/openwrt-$(BOARD)-root.$(1)" \
+ $(call imgname,$(1),$(2))-sysupgrade.bin
endef
define Image/Build/Planex
@@ -431,6 +435,11 @@ endef
define Image/Build/squashfs
$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+ dd if=$(KDIR)/root.squashfs of=$(KDIR)/root.squashfs-4k.tmp0 bs=4k conv=sync
+ $(call add_jffs2_mark,$(KDIR)/root.squashfs-4k.tmp0)
+ dd if=$(KDIR)/root.squashfs-4k.tmp0 of=$(IMGNAME)-root.squashfs-4k bs=4k conv=sync
+ $(call add_jffs2_mark,$(IMGNAME)-root.squashfs-4k)
+ rm -f $(KDIR)/root.squashfs-4k.tmp0
endef
define Image/Build